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Enhancements/Features 

Added Integration with Manitou Web Client Autodial and Five9 Telephony 

We enabled Manitou’s Autodial to operate with the Five9 telephony system, to set the caller ID, and the 

hang up functionality.  

Please see additional information on use and setup here: https://manitou-knowledge-

base.knowledgeowl.com/help/five9-softphone-and-manitou-integration 

Updated the GoTo Connect/Jive Integration  

GoTo Connect/Jive will be updating their API host endpoint beginning on August 28th, 2024. We updated 

Manitou to the new API host endpoint. We also updated that if it is enabled in Jive, when we dial, the user 

no longer has to select “answer” for the call before it begins dialing in Jive. There is a change to the Jive 

permissions that must be updated for the changes. Please see the following documentation for those 

changes: https://manitou-knowledge-base.knowledgeowl.com/help/goto-connect-update-to-jive-

permissions. 

Added Integration with Default Application Auto-Dialer 

We added a new dialer type of Default Application. This allows users to select from any phone-type 

application on their computer as the default dialer within the Manitou Web Client. All configuration needs 

to be within the phone application, the MWC will only launch the application and include the phone 

number. Please see additional information on use and setup here: https://manitou-knowledge-

base.knowledgeowl.com/help/default-application-auto-dialer-integration-with-the-manitou-web-client. 

Application Corrections 

Billing Charges/Rates are showing at the Monitoring Company Level in the Web Client 

(Manitou and BoldNet) when visible permission has been removed [00102788] 

Issue: When trying to remove “Visible” for Billing Rates and Charges Under Monitoring Company it was not 

respecting permissions. Users logged into either Manitou Web Client (MWC) or BoldNet with Visible and 

edit unchecked were still able to see “Billing” under the Monitoring Company level. 

Solution: When set in Supervisor Workstation permissions for visible and edit now work properly for 

monitoring company billing in the MWC. 

https://manitou-knowledge-base.knowledgeowl.com/help/five9-softphone-and-manitou-integration
https://manitou-knowledge-base.knowledgeowl.com/help/five9-softphone-and-manitou-integration
https://manitou-knowledge-base.knowledgeowl.com/help/goto-connect-update-to-jive-permissions
https://manitou-knowledge-base.knowledgeowl.com/help/goto-connect-update-to-jive-permissions
https://manitou-knowledge-base.knowledgeowl.com/help/default-application-auto-dialer-integration-with-the-manitou-web-client
https://manitou-knowledge-base.knowledgeowl.com/help/default-application-auto-dialer-integration-with-the-manitou-web-client
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Unable to Browse Dealer with an apostrophe in the Dealer ID [00092290] 

Issue: Dealers that had an apostrophe in the Dealer ID would not load anything past the main page in the 

MWC. 

Solution: We fixed this so now Dealer IDs with apostrophes work correctly in menus and submenus and 

can be used as intended. 

Turkish Characters are not supported in web client reports [00105071] 

Issue: Turkish characters (such as ğ, ı, ş, ç, etc.) were not supported in the MWC generated reports CSV 

export, although they appeared normally in the MWC and the PDF version of the report. 

Solution: This was both an Operator Workstation (OWS) and MWC issue. We corrected this so now when 

CSV file is selected as the exported attachment, it contains the accented characters from different 

languages, for example, Turkish, Hungarian, etc. If users open the CSV file with notepad the accented 

characters will be visible. 

To open the file in Microsoft Excel, users need to import the file.  

Click on the Data tab. Then select Get Data > From File > From Text/CSV. Select the CSV file. Make certain 

“File Origin” has “65001: Unicode (UTF-8)” selected before clicking Load. Once loaded, accented 

characters will be visible. 

When editing the “CUSTOMER” on the contact list, there is no box to suppress or 

unsuppress the contact [00085964] 

Issue: Missing Suppress checkbox in the MWC. 

Solution: We added a checkbox to the edit form to suppress in the contact list for customer, agency, and 

dealer entries in the MWC. 

Auto Purge not working for temp comments [00097968] 

Issue: The auto purge selection was not working on temp comments. Once the comment expired, it went 

to the Expired section and stayed there, whether or not auto purge was selected. 

Solution: There was an issue with Temporary Comments that had the Auto Purge checkbox checked. The 

Overdue Checker selects expired Temporary Comments flagged as "Auto Purge" and deletes them from 

the system. This was not working as expected but has now been fixed. 
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Users should be aware of these: 

1) The Number of hours before purging expired temporary comments field requires a value 

greater than 0 for the Temporary Comments to be auto deleted. A value of 0 indicates no auto 

deletion. This is found in Supervisor WorkStation > Tools > Options > Purge section. 

2) The purging of Temporary Comments process only happens once an hour at the 15 minute mark. 

If the Overdue Checker process is started within 5 minutes before the 15 minute mark, the 

deletion is pushed to the next hour. 

Monitoring Company Report Parameters not staying [00054051] 

Issue: While adding an audit trail report on monitoring level by Branch ID, once saved it was removing the 

Branch ID parameters on the report. Note: When the report runs it was still holding the Branch ID in the 

parameters, but it was not visible. 

Solution: Audit Trail reports in Operator Workstation now accurately reflects the chosen IDs upon edit. 

Binary data in the Activity Log not loading into the VCC when the date format is 

dd/mm/yyyy [00109681, 110454] 

Issue: When trying to view video from the Activity Log and the native date format was not mm/dd/yyyy the 

VCC would open but only display a blank window. 

Solution: We corrected this so that regardless of the date format the Activity Log video (binary) displays. 

Web Client: Unable to move plans around without side menu continuously opening/closing 

[00105571] 

Issue: When moving a plan around in the plan box area the left and right navigation panes would show. 

Solution: We removed the navigation panes from showing when moving a plan around within the plans 

page. 

Web Client: Typing Directionals in Labels causes entire plan to shift [00109314] 

Issue: When editing a label box description, typing directional keys such as arrow keys, +, -, or = caused 

the plan to shift, get larger, or get smaller. 

Solution: We corrected the focus on the Label box so that typing directional keys in the description no 

longer shifts the plans. 
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Web Client: Removing a Contact that is listed as a destination for a scheduled report, 

removes the reports parameters from the database [00106253] 

Issue: When deleting a contact from the Contact List page, and that contact was set as a destination for 

an existing Scheduled report, the report’s parameters that were set in the database were deleted. This 

caused the report to go out blank or error that there is no vCLOG available. 

Solution: We fixed multiple issues with scheduled reports. We corrected the behavior of deleting the 

report’s parameters in the database when a destination Contact is deleted. We also corrected an issue 

where some report’s selection and checkboxes would not show as they should on edit and default values 

would show instead. They now show on edit as expected. In addition, we fixed an error that would 

happen when trying to add multiple contacts at the same time to the destination of the report. 

Web Client: Contact’s name not showing when adding as a destination for a scheduled 

report 

Issue: Adding contacts as a destination for a scheduled report was showing with the name field blank, and 

only the email address displayed until the report was saved. 

Solution: We corrected two issues with report destination emails. We corrected the situation where the 

name would not appear when adding a contact’s email to the report’s destination. We also corrected the 

situation where it was not displaying all contacts until the report was saved. It now shows the listing as 

the destinations are modified. 

Web Client: Unable to remove system access from new Contacts [00103597] 

Issue: When creating new contacts in an account, all systems except system 1 were showing as selected 

and the checkbox to unselect them could not be removed. 

Solution: We added the ability to toggle contacts’ access to systems without areas. Now all system 

accesses can be toggled for contacts. We added error messaging for missing information in fields (for 

example, missing panel user IDs for selected areas/systems). Systems now expand when checked to show 

potential errors in nested areas. 

Web Client: Pre-Cancel Form does not focus input to Customer ID field [00099772] 

Issue: When loading up the Pre-Cancel form from the hotkey (F9) or from the file Menu > Operations > Pre-

Cancel, the cursor was not auto focused in the Customer ID field. 

Solution: The initial focus is now the Customer ID field on the Pre-Cancel form, in addition we corrected 

the same behavior on the On Test form and the Manual Signal form. These forms now auto-focus in the 

Customer ID field when opened from the file menu or from a hotkey. 
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SureView stops receiving signals [00102070] 

Issue: The SureView servers appeared to be restarting too quickly and SureView did not know that the 

original process stopped and restarted. 

Solution: We added a parameter called “ReconnectWait” to adjust the time it takes for a reconnection to 

proceed. This parameter is in the App.config file that holds the number of seconds to wait. The default is 1 

second as before. 

Database Changes 

None for this release. 

System Requirements 

Minimum System Requirements 

▪ Windows Server 2016 

▪ 8 GB Memory 

▪ Dual Core Processor 

▪ Microsoft® SQL Express 2016 / Microsoft SQL Server 2016 

▪ 50 GB of Free Space for Database 

▪ Windows 10 for Operator Workstations 

TLS 1.2 is supported, and ALL servers should be configured to support this. The Nartac IIS Crypto tool is 

very useful for verifying this is supported. 

.NET 4.8 is required for full compatibility with current updates of the PBX server and several other Manitou 

components. https://docs.microsoft.com/en-us/dotnet/framework/get-started/system-requirements  

If you are updating Media Gateway, PBX Server, or LocationServer please make sure that the latest 

Microsoft OLEDB drivers are installed. This should just be done on ALL servers. 

https://docs.microsoft.com/en-us/sql/connect/oledb/download-oledb-driver-for-sql-server?view=sql-

server-ver15.  

.Net 4.8 is needed for VCC on workstations that use ONVIF or Avigilon 7 drivers. 

Manitou Web Clients and BoldNet require the use of a certificate issued by a valid certificate authority. We 

do not support the use of invalid self-signed certificates in a production environment. 

https://docs.microsoft.com/en-us/dotnet/framework/get-started/system-requirements
https://docs.microsoft.com/en-us/sql/connect/oledb/download-oledb-driver-for-sql-server?view=sql-server-ver15
https://docs.microsoft.com/en-us/sql/connect/oledb/download-oledb-driver-for-sql-server?view=sql-server-ver15
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End-of-Support 

Microsoft periodically ends support for some products. Due to this we can no longer support the 

following: 

▪ Windows Server 2012 R2 (Please Note: Microsoft ended support for this product October 10, 2023 

https://learn.microsoft.com/en-us/lifecycle/products/windows-server-2012-r2) 

▪ Microsoft® SQL Express 2012 / Microsoft SQL Server 2012 (Please Note: Microsoft ended support for 

this product July 12, 2022 https://learn.microsoft.com/en-us/lifecycle/products/microsoft-sql-

server-2012) 

▪ Windows Server 2008 and older 

▪ Microsoft SQL Server 2008 R2 and older 

▪ Windows 7 and older 

https://learn.microsoft.com/en-us/lifecycle/products/windows-server-2012-r2
https://learn.microsoft.com/en-us/lifecycle/products/microsoft-sql-server-2012
https://learn.microsoft.com/en-us/lifecycle/products/microsoft-sql-server-2012
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