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Manitou 2.1.34 Release Notes 
New Development 

We added several privacy enhancements around Entity passwords 
 
Fixed, Resolved, and Addressed 

We fixed an issue that prevented the Activity Log from being refreshed when submitting scripts 
We adressed an issue that caused Must Contact not to work when followed by logic 
We resolved an issue that prevented the Show command from logging Comment detail 
We fixed an issue that prevented users in Turkey from logging in 
We addressed an issue that caused Web Client search results not to be complete 
We resolved an issue that prevented some Alarm Handling keyboard shortcuts from working 
We fixed an issue that errors in Action Pattern Connect commands 
We addressed an issue that caused ‘No Workstation ID Found’ messages 
We resolved an issue that caused response times to be off by 2 seconds 
We fixed an issue that made IM Messages unreadable in Dark Mode 
We improved how Enhanced Scripts are copied 
We addressed an issue that may have made addresses slightly harder to read 
We resolved an issue that caused incorrect dates to be displayed on Maintenance Issues 
We fixed an issue that prevented copying Customers in BoldNet NEO 
We addressed an issue that appeared to text on Event Code descriptions on Transmitter Types 
We resolved an issue that prevented Operators from viewing activity older than 1 week 
We fixed an issue that prevented Reverse Commands from being sent 
We addressed an issue that slowed dispositioning of calls in the Manitou Web Client 
We added a JSON parser to the SMS Listener 
We resolved an issue that prevented maps from being displayed in the Manitou Web Client 
We fixed an issue that incorrectly changed Alarm Handler state 
We addressed an issue that caused User Status to incorrectly show Alarm Handling Status 
We resolved an issue that prevented editing Event Action Programming in some cases 
We fixed an issue that prevented System Log from correctly showing Alarm Handling Status 
We addressed an issue that prevented Script Messages from being demoed properly 
We resolved an issue that appeared to un-pause Alarm Handling 
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Features and Enhancements 
 
27118 – We added several privacy enhancements around Entity passwords 

What changed? 
- An Option was added to Supervisor Workstation to enhance Password privacy (more below) 
- Logging was added to Customer Activity Log to indicate when passwords were verified 
- Logging was added to System Log to indicate when private passwords were revealed 
Why was there a change? 
There were requests from customers for additional security around Entity passwords 
How does this change impact the user? 
Users who enable the option (details below) will mask passwords in validation boxes, and add 
additional logging to the Customer Activity Log and System Log: 

Masking in the validation box: 
In any place where the validation box is present, if the operator chooses 'Other' or it is 
customer driven validation, such as in alarm handling, the passwords will be shown as masked  

 
The Operator may do a blind-type of the contact password and tab to still have the password 
validate. The Operator may unmask the contacts password to verify, click the password to 
select it and validate it.  If the Operator does a blind-typing of the password and the password 
belongs to more than one contact, a message box will show that states the Operator must 
select a contact out of the contact list. 

 
There is also the ability to select a contact.  Selecting a contact will show the contact with a 
green checkmark on it.  The Operator can de-select the contact by clicking on the contact again. 
The unmasking of a password works by clicking the eyeball icon next to the password. The 
password can be re-masked by clicking the eyeball icon again. If an Operator selects a contact 
from the list, then blindly-types the password, if the password does not match the selected 
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contact, they will get an error message that states the User ID and /or Password are invalid. If 
the Operator selects a contact but unmasks and selects a password on a different contact 
they will get an error stating the User ID and/or Password are invalid. They will need to 
deselect the contact, and select the correct contact to the corresponding password.  

 
If the password matches the selected contact, the password will validate.  

Attempts at password verification will appear in the customer's Activity Log as either a 
PASSWORD verified or a PASSWORD not verified. When logged into BoldNet the log details will 
show the user that is logged in versus the password that was verified 

 
Logging for unmasking will show in the Hamburger Menu>Tools>System Log under the 
Category of 'Miscellaneous' and Qualifier 'Private Password Revealed'.  It will show the User ID 
that unmasked the password and the Event Text will shows which Contact password was 
unmasked. 

 
 
What does the user need to do differently as a result? 
The Option (Supervisor Workstation > Tools > Options > Account Creation/Maintenance > Mask 
Passwords on Manitou CS Web Client/BoldNet validation dialogs) has two options. Selecting No, which 
is the default, will keep password display functionality the same as it always was. Selecting Yes will 
impact the users as mentioned in the “How does this change impact the user” section above. 
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Fixes 
25149 – We fixed an issue that prevented the Activity Log from being refreshed when submitting scripts 

What This means for you: Users of the Manitou Web Client, when submitting a script that came up as 
a part of an action pattern, were seeing that the Customer Activity Log was not being refreshed. This 
behavior is different from the Legacy Client. This behavior has been corrected so that the Customer 
Activity is refreshed when scripts are submitted. 
 

22530 – We addressed an issue that caused Must Contact not to work when followed by logic 
What This means for you: If an Enhanced Action Pattern contained Logic, the “Must Contact” was not 
being respected. The underlying code was reworked to account for the inclusion of logic, and Must 
Contact will be respected again. 
 

22536 – We resolved an issue that prevented the Show command from logging Comment detail 
What This means for you: When using the Show command in an action pattern to show Comments, it 
does (correctly) take the operator to the correct comment, but fails to show the title of the Comment 
in the activity log (which it did in 1.6.4). This has been resolved. 
 

26369 – We fixed an issue that prevented users in Turkey from logging in 
What This means for you: Turkish users were getting stuck on the loading screen. This fix addresses 
the issue with Turkish customers (as well as others that were likely caused by the same locale issues. 
 

18467 – We addressed an issue that caused Web Client search results not to be complete 
What This means for you: It was reported that the Web Client sometimes shows a smaller list of 
search results for the same search. It was discovered that the search function in the Web Client was 
limited to 50 characters in some fields that contained more than 50 characters. This caused the Web 
Client to return a truncated set of results. This has been addressed. 
 

24417 – We resolved an issue that prevented some Alarm Handling keyboard shortcuts from working 
What This means for you: The Legacy client included several keyboard shortcuts that allowed 
operators to use the keyboard shortcuts to view ribbon notifications (A>H>M, for example, displays 
Maintenance Issue notification). Previously in the Web Client, the A shortcut would launch the Action 
Menu correctly, but pushing H would switch it to the Hold menu. This has been resolved, and the same 
shortcuts work in the web client now. 
 

25956 – We fixed an issue that errors in Action Pattern Connect commands 
What This means for you: Some users upgrading from 1.6.4 to 2.1 were seeing issues where some 
Connect commands in action patterns (Connect commands that were intended to connect to specific 
devices) were not working in 2.1. This was happening because of a script that was not applied during 
the update. This is resolved for future upgrades. Users who are seeing (WARNING: DEVICE NOT 
FOUND) in action patterns should contact support for a fix. 
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25962 – We addressed an issue that caused ‘No Workstation ID Found’ messages 

What This means for you: Some users were seeing a message indicating a workstation ID could not be 
found when using the web client. Specifically, users were able to use the Legacy client on the same 
machine with no problem. Logging was added to the Local Utility Service to identify the workstation ID 
being sent. 
 

23854 – We resolved an issue that caused response times to be off by 2 seconds 
What This means for you: Users reported that response times appeared to be off by 2 seconds. We 
adjusted the way the response times are calculated. This issue has been resolved. 
 

25142 – We fixed an issue that made IM Messages unreadable in Dark Mode 
What This means for you: Users who use the Dark Mode theme in the Manitou Web Client were 
unable to read the text of IM messages because the colors did not contrast enough. The control that 
displays the IM messages has been updated, and now takes Dark Mode into consideration when 
displaying text. 
 

25147 – We improved how Enhanced Scripts are copied 
What This means for you: Previously, when copying an enhanced script, only the name was copied.  
Script lines now persist when creating an enhanced script based on an existing. Note that, if a script is 
copied, the new script will be the same type as the one being copied. 
 

26712 – We addressed an issue that may have made addresses slightly harder to read 
What This means for you: Users of the Manitou Web Client reported that, if they clicked on a 
Comments alarm notification, the tooltip labeled “Comments” remained on the screen and hid part of 
the Customer Name and Address: 

 
This has been updated so the tooltip now displays above the Comments icon: 

 
 

25145 – We resolved an issue that caused incorrect dates to be displayed on Maintenance Issues 
What This means for you: Maintenance Issues were being displayed with logged times showing in UTC 
time. We resolved the underlying issue and Maintenance Issues now display times correctly. 
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22554,25998 – We fixed an issue that prevented copying Customers in BoldNet NEO 

What This means for you: Users of BoldNet NEO were reporting that they received errors when 
copying Customer accounts stating “Customer Not Found”. We adjusted how the database commands 
were applied on the database, fixing this issue. 
 

27182 – We addressed an issue that appeared to truncate text on Event Code descriptions on TXTypes 
What This means for you: Users of the Manitou Web Client reported that, when typing descriptions 
(just to the right of Event Code) on the Transmitter Types Programming screen, the descriptions were 
getting cut off. This database field only allows 20 characters, and the Manitou Web Client was allowing 
more characters to be entered. The Web Client now limits data entry to 20 characters preventing 
confusion in the future. 
 

26713 – We resolved an issue that prevented Operators from viewing activity older than 1 week 
What This means for you: Alarm Operators were reporting that, in the Manitou Web Client, when 
attempting to change the filter from Week to Month, only the most recent week was being displayed. 
We resolved the underlying issue. 
 

24888 – We fixed an issue that prevented Reverse Commands from being sent 
What This means for you: Alarm Operators reported that they were unsuccessful in sending Reverse 
Commands in the Manitou Web Client. Opening the Manitou Legacy Client allowed these commands to 
be sent. We adjusted how the commands were parsed in the Manitou Web Client and the Reverse 
Command functionality has been restored. 
 

25144 – We addressed an issue that slowed dispositioning of calls in the Manitou Web Client 
What This means for you: Alarm Operators who are handling Alarms for Two-Way audio customers 
reported that, if the Audio icon is accidentally selected in the Ribbon area in the top left, the Operators 
were forced to take several steps to acknowledge that they did not, in fact, want to contact that 
customer. This was causing a problem when there was no audio connected. Manitou will now display 
the Audio icon if audio is still available. 
 

27972 – We added a JSON parser to the SMS Listener 
What This means for you: There was a request to add support for parsing incoming JSON formatted 
SMS messages. This has been added. 
 

24787 – We resolved an issue that prevented maps from being displayed in the Manitou Web Client 
What This means for you: Users who attempted to view addresses on GPS alarms were seeing an error 
stating “Couldn’t initialize web view because the initialization field OBJ_MESSAGE could not be 
fetched. The underlying issue that caused this error has been resolved. 
 

27978 – We fixed an issue that incorrectly changed Alarm Handler state 
What This means for you: Users who had the Alarm Handling Option set to Only in Alarm Handling 
(Supervisor Workstation > Tools > Options > Alarm Handling > Alarm Handling Mode > Alarm Handling 



 

4050 Lee Vance Dr, Suite 250  
Colorado Springs, CO 80918   
boldsales@boldgroup.com 

www.boldgroup.com   
 
   

status activated only in Alarm Handling) reported that, when they closed the Alarm Queue, the 
operator was removed from Alarm Handling. This has been fixed. 
 

27228 – We addressed an issue that caused User Status to incorrectly show Alarm Handling Status 
What This means for you: The User Status screen (Supervisor Workstation > View > User Status) was 
incorrectly showing the Alarm Handling status of some users. This was happening because the Manitou 
Web Client was launching the Alarm Queue when exiting Alarm Handling. This behavior has changed, 
and the Alarm Queue will now be displayed only if it was already open when exiting Alarm Handling. 
 

27181 – We resolved an issue that prevented editing Event Action Programming in some cases 
What This means for you: When attempting to edit Event Action Programming (lower left of Customer 
programming screen) for customers who have more than 500 lines of programming, some users were 
seeing Manitou become unresponsive. We changed how this screen is edited, allowing edit to one item 
at a time. 
 

26541 – We fixed an issue that prevented System Log from correctly showing Alarm Handling Status 
What This means for you: When Comparing the Operator Status (Supervisor Workstation > View > 
User Status) for a specific time to the System Log (Supervisor Workstation > Tools > System Log), the 
System Log was not correctly reflecting the Alarm Handling Mode (Manual vs Autoget). This has been 
resolved. 
 

26715 – We addressed an issue that prevented Script Messages from being demoed properly 
What This means for you: In the Script Messages screen (Supervisor Workstation > Maintenance > 
Script Messages), if the Demo button is pressed, correct demo information was not being displayed. 
This has been addressed. 
 

25143 – We resolved an issue that appeared to un-pause Alarm Handling 
What This means for you: Operators who paused Alarm Handling, stepped away, and returned found 
Alarms on their screen. The underlying cause was resolved. 
 

28756 – We added the ability to use the Equal Sign (=) for Event Code on Enhanced Action Patterns 
What This means for you: Previously, when using the Escalate command on action patterns, you were 
not able to specify the Equal Sign for event code (meaning that, with an Equal Sign, the new alarm will 
be created with the same Event Code as the action pattern: 

 
 

 


