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OVERVIEW 

The Standard Import Utility is used to import data into Manitou by using either data files or 

the Common Import Database (CID). This document will explain how data should be added 

to the Common Import Database or how files should be organized so that importing data is 

efficient and less prone to import failures. 

 

USING THE COMMON IMPORT DATABASE AS SOURCE DATA 

Standard Import can use data from a special set of tables called the Common Import 

Database (CID) as source data.  The tables of the CID are created by Standard Import, 

populated by the user, and queried by Standard Import to generate an import file. 

When using the CID as the primary import source, Standard Import divides the work of 

importing into two steps.  First, Standard Import queries the CID tables and generates an 

import file.  Second, this import file is sent to the Main Processor for normal processing.  

This has several implications.  If an error is encountered during the first step, Standard 

Import will halt immediately. The user can then correct the error in the CID, resume the 

process, and Standard Import will begin where it left off.  If an error is encountered during 

the second step, Standard Import reports those errors just as it would if the source data 

were coming from a user-defined import file, giving line numbers and column information 

for the error.   

For a full import (as opposed to Test Mode), second-step errors result in Standard Import 

marking CID records with an incremental number. This number also displays in the error 

message text surrounded by brackets.  You can use the number reported in the error 

message text to locate the offending row in the CID, make the necessary corrections, and 

restart the import process.  You may continue this process until no errors are discovered 

and the import completes successfully. 

 

COMMON IMPORT DATABASE SCHEMA 

 

The CID Schema matches that of the Record Definitions section below with the 

following exceptions: 

 

• Each table in the CID is named StdImpSECTION_NAME where SECTION_NAME is 

the name of the import file section defining the record data.  For example, the 

table holding PANELTYPE information would be named StdImpPANELTYPE. 

• There are two additional columns in each table that do not correspond to any of 

the column names in the record definition.  These should never be augmented by 

the user.  _IMPORTED and _ERRNO are the last two columns of the table.  

_IMPORTED is set to “1” by Standard Import when that row has been 
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successfully queried and added to the generated import file.  _ERRNO can be 

used to locate errors reported by Standard Import in the CID so that the user 

may correct them. 

• Some tables may have a column whose name is preceded by an underscore (for 

example, “_SEQ").  This column is an auto-ID field and cannot be populated by 

the user. 

 

USING IMPORT FILES AS SOURCE DATA 

Standard Import can use one or more import files as source data.  The import files contain 

data in a particular format and order.  Even when using the Common Import Database, 

Standard Import will generate an import file and base its error reporting off of this file, so it 

is important to be capable of reading it. 

 

Syntax 

An import file contains two different elements: comments (inline or block) and records 

(data). 
 

Comments 

Comments may be inline or block. Inline comments apply solely to a specific line and 

must begin with two forward slashes (//). Any text on that line following the slashes 

is ignored by Standard Import.  

Block comments apply to all text between two symbols - the begin comment symbol 

(/*) and the end comment symbol (*/). These can appear anywhere in the file. All 

text between the two symbols is ignored by Standard Import.  

Note: An exception exists when the symbols appear inside a quoted string. When a 

quoted string is present, Standard Import recognizes the text.  

 

Records 

Data lines, or records, must appear on a single line and in a specific format. Each 

data element within a record is called a data field, and all data fields are separated 

by commas. For example: 

 

1016,"CUST-001","Customer 001",,0,1,"USENG","GMT-05:00",1,,1, 0, 

"Main Street","Whispering Pines",,, 

 

Data Line Syntax Rules 
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1. Each data line contains a numeric code indicating the type of record being 

defined.  In the example above, 1016 is the code for a CUSTOMER record.  (See 

the Data Record Numeric Codes section below for a list of all record types and 

their corresponding numeric codes.) 

2. Each data line is a single line with no carriage return. To insert carriage returns 

in a quoted string, use the ASCII character 1. This character will be interpreted 

as a carriage return and will be stored in the database as a carriage return upon 

importing. 

3. Each data field is separated by a comma. When a data field is optional, a comma 

is used to separate the optional field from the following field. This is done 

because the Standard Import must know that this data field is accounted for, 

even if the data does not exist. In the previous example, the data line ends in a 

comma because the final field is optional. 

4. Spaces between fields are ignored. 

5. String (or textual) data is delineated by double quotation marks. This allows you 

to use commas or other symbols (such as #, / / , /* or commas) inside the string 

so the utility knows not to interpret them. If a double quotation mark is needed 

inside the string, use two consecutive double quotation marks with no inserted 

spaces ( for e.g.,  "A string with ""double"" quotes"). 
 

Record Definition 

In addition to basic syntax checking, the data provided is checked semantically 

based on the record definition. The record definition shows how many data fields 

are expected for the record, the type of data for each data field, and whether or not 

the data field is optional. 

Semantic Rules for a Data Line 

1. The data field count is verified. If the record definition indicates ten data fields, 

the user must provide a position for ten fields, even if some of the fields are 

optional. For example, there should be nine commas in the data line separating 

the ten data fields.  

2. The length of the string is verified. Strings exceeding the data field length in the 

record definition will produce a warning and will be truncated.  

3. The data type of the data field is verified.  The following is a summary of all data 

types: 

• STRING: Mixed-case textual data 

• CODE: Upper-case textual data 

• LONGTEXT: Mixed-case textual data of variable size 

• YES/NO: Either 1 (Yes) or 0 (No) 

• VALUE: A positive or negative integer number 

• MONEY: A positive or negative floating point number, such as 12.50 

• DATE: A date value in one of the following formats: "MM/dd/yyyy", "MM-dd-

yyyy" 

• TIME: A time value in one of the following formats: "HH:mm:ss", "HH:mm" 
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• DATETIME: A date/time value in one of the following formats: "MM/dd/yyyy 

H:mm:ss", "MM/dd/yyyy", "MM-dd-yyyy HH:mm:ss", "MM-dd-yyyy" 

4. Some data fields refer to other data already defined in the database or in one of 

the existing data records. For example, the ADDRESS record requires a Region 

name which must be in the database. The import utility will check to see if the 

data provided is valid. 

5. Some data fields can only accept certain values, such as a range of numbers from 

1-10 or codes "A", "B", or "C". These values are checked against the record 

definition for validity.  

If a VALUE data field is OPTIONAL in the record definition, in most cases it will 

be interpreted as zero or NULL if no data is supplied.  (Note that the Application 

Server may choose to default this value.) 
 

Organizing Data Files 

 

Ordering records in the data files is extremely important, as it ensures efficiency and 

provides the import utility with appropriate references. References are necessary and 

show what entities certain data records belong to. For example, an ADDRESS record 

must belong to an entity, such as a CUSTOMER: 

 

// CUSTOMER 

1016, "CUST-001","Customer 001",,0,1,"USENG","GMT-05:00",1,,1, 0,  

"Main Street","Whispering Pines",,, 

 

// ADDRESS 

1003, 1,"CUST-001",,0,"548 Crider Avenue",,"Boomtown","OHIO","44663",1 

 

In this example, the second and third data fields of the ADDRESS record (ContType and 

ContID) are references to the data line in the CUSTOMER section above it.  The 

ADDRESS record must come after the CUSTOMER record because it references it.  

Placing the ADDRESS record before the CUSTOMER record will produce an error. 

 

Entity Grouping 
 

Data records should be grouped according to a single entity.  This allows the utility 

to work with a single entity at a time and therefore be as efficient as possible. 

Though grouping data in this way is not necessary, spreading out data for an entity 

over the file or files significantly reduces efficiency. Importing data grouped 

according to a single entity is three times faster than importing data grouped by 

record type.  For example: 

 

// ------------------------------------------------ 

// Data for Customer 001 
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// CUSTOMER 

1016, "CUST-001","Customer 001",,0,1,"USENG","GMT-05:00",1,,1,0,  

"Main Street","Whispering Pines",,, 

 

// ADDRESS 

1003, 1,"CUST-001",,0,"548 Crider Avenue",,”Boomtown”,”OHIO”, 

"44663",1, 

 

// ------------------------------------------------ 

// Data for Customer 002 

// CUSTOMER 

1016, "CUST-002","Customer 002",,0,1,"USENG","GMT-05:00",1,,1,0, 

"Pine Avenue","Edgemont Ranch",,, 

 

// ADDRESS 

1003, 1,"CUST-002",,0,"123 Pine Avenue",,”Boomtown”,”OHIO”, 

"44663",1, 

 

In the example above, data records are grouped together by Customer. This is the 

most efficient way to import data.  

 

Note: When using multiple import files, an entity should not span multiple files. 

When the utility hits the end of the file, it assumes the entity is being switched and 

goes ahead and imports it. 

 

The following example is a suggested order of data records in a file: 

 

NON-ENTITY DATA 

TXTYPE, PANELTYPE, TXEVENTPRG, TXTYPEPRG 

 

PERSON 

PERSON, GENSCHED, GENSCHED_D, CONTPOINT, ADDRESS, ALTCONTACT, 

COMMENTS 

 

BRANCH 

BRANCH, GENSCHED, GENSCHED_D, CONTLIST, CONTPOINT, CALLLIST, 

CALLLIST_D, ADDRESS, ALTCONTACT, ATTN, COMMENTS 

 

AGENCY 
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AGENCY, GENSCHED, GENSCHED_D, CONTLIST, CONTPOINT, CALLLIST, 

CALLLIST_D, ADDRESS, ALTCONTACT, ATTN, COMMENTS 

 

AUTHORITY 

AUTHORITY, GENSCHED, GENSCHED_D, CONTLIST, CONTPOINT, CALLLIST, 

CALLLIST_D, ADDRESS, ALTCONTACT, ATTN, COMMENTS 

 

INSTALLER 

INSTALLER, GENSCHED, GENSCHED_D, CONTLIST, CONTPOINT, CALLLIST, 

CALLLIST_D, ACTIONS, ACTIONS_D, ATTN, INSTCP, INSTRATE, INSTRATE_D, 

ADDRESS, ALTCONTACT, COMMENTS, INSTCHG, INSTEVPRG, INSTTX, INSTIDRNG 

 

CUSTOMER 

CUSTOMER, CUSTSYS, AC_SECTOR, GENSCHED, GENSCHED_D, OC_SCHED, 

OC_SCHED_D, SAREA, CONTLIST, CONTLIST_D, CONTPOINT, CALLLIST, CALLLIST_D, 

ACTIONS, ACTIONS_D, ATTN, STX, EVENTPRG, SZONES, SASSET, REMINDER, 

STXLINK, STXPRG, ADDRESS, ALTCONTACT, COMMENTS, CUSTOPTIONS, CUSTPW, 

CUSTUFLD, PERMIT 

 

CLOG 

CLOG 

 

Caveats 
 

• When you run the Standard Import Utility for the first time, you must run it 

as an Administrator. Running the application for the first time as a regular 

user may result in error. 

• In the case of Customer sub-accounts (including STXLINK records where a 

sub-account is referenced), the sub-account should precede the main account 

in the file.  

• Some records require two or more passes to be completely imported.  Be 

aware that, in Test Mode, these records may produce reference errors that 

can be completely resolved in Full Import Mode. 

• Certain records must be grouped together and may not be spread through 

the data file or files.  These include records that are required for a minimum 

store. For example, the main entity and its ADDRESS record cannot be 

separated, because a minimum entity store requires both of these. CALLLIST 

and CALLLIST_D for a single entity must display together (all Call Lists may 
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be given, then their details). ACTIONS and ACTIONS_D for a single entity 

must display together (all Actions may be given, then their details). 

OC_SCHED and OC_SCHED_D for a single entity must display together (all 

Schedule headers may be given, then their details). 

 

DATA RECORD NUMERIC CODES 

Each data record type has a corresponding numeric code that must be given as the first 

column of the data record.  This code identifies the type of the data record.  The following is 

a list of all record types and their numeric codes: 

AC_SECTOR 1000 

ACTIONS 1001 

ACTIONS_D 1002 

ADDRESS 1003 

AGENCY 1004 

ALTCONTACT 1005 

ATTN 1006 

AUTHORITY 1007 

BRANCH 1008 

CALLLIST 1009 

CALLLIST_D 1010 

CLOG 1011 

COMMENTS 1012 

CONTLIST 1013 

CONTLIST_D 1014 

CONTPOINT 1015 

CUSTOMER 1016 

CUSTOPTIONS 1017 

CUSTPW 1018 

CUSTSYS 1019 

CUSTUFLD 1020 

EVENTPRG 1021 

GENSCHED 1022 

GENSCHED_D 1023 

INSTALLER 1024 

INSTCHG 1025 

INSTCP 1026 
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INSTEVPRG 1027 

INSTIDRNG 1028 

INSTRATE 1029 

INSTRATE_D 1030 

INSTTX 1031 

MONSRV 1052 

OC_SCHED 1032 

OC_SCHED_D 1033 

PANELTYPE 1034  

PERMIT 1035 

PERSON 1036 

REMINDER 1037 

SAREA 1038 

SASSET 1039 

STX 1040 

STXLINK 1041 

STXPRG 1042 

SZONES 1043 

TXEVENTPRG 1044 

TXTYPE 1045 

TXTYPEPRG 1046 

 

Record Definitions 

The following is a list of all record definitions the Standard Import Utility is capable of 

importing. Although the following record definitions do not explicitly show it, the first 

column of each data record is always the data record type’s numeric code. 

 

CUSTOMER (1016) 

An example of a CUSTOMER string is represented by the following: 

// Customer 

1016,"SIUTEST0002","Test customer 0001 for the SIU2345678901234567890","TEST 

CUSTOMER 0001 FOR THE SIU2345678901234567890",0,1,"USENG","GMT-

06:00",0,"SIUTEST0001",,1,"Cross 

Street34567890123456789012345","Subdivision234567890123456789012345","","","",0, 

 

 

CONTID must be unique. 
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CONTID: CODE(12) 

 

This specifies the new customer’s Customer ID. 

 

FULLNAME: STRING(50) 

 

This is the customer’s name. 

 

FILEAS: STRING(50): OPTIONAL 

 

This field is used to search for a Customer by name and will be converted to be all 

upper case.  Residential names should normally be given as “Last Name, First 

Name(s)”.  If left blank, the utility will use the FULLNAME value.  For Customers 

with a SUBTYPE of 0 (residential), the utility will take the last ‘word’ of the 

FULLNAME and put it at the beginning followed by a comma and a space, then the 

rest of the FULLNAME.  If the FULLNAME for a Customer record with a SUBTYPE of 

0 is “Joe Smith Jr.”, and FILEAS is left blank, then the utility will cause FILEAS to be 

“JR., JOE SMITH” since it sees ‘Jr.’ as the last word.  The import data can properly set 

FILEAS to be ‘SMITH JR., JOE” in these cases. 

 

TIMEFMT: VALUE: OPTIONAL  

 

This refers to the time format to be shown on reports sent to this customer and can 

be one of the following values: 0=format specified in the Country definition 

(default), 1=12-hour time format, 2=24-hour time format. 

 

COUNTRY: VALUE 

 

The must reference a valid country in the receiving Manitou database (here and all 

other occurrences). 

 

LOCALE: CODE(5) 

 

This must reference a valid locale in the receiving Manitou database (here and all 

other occurrences). 

 

TIMEZONE: CODE(15) 

 

This must reference a valid time zone in the receiving Manitou database (here and 

all other occurrences). 

 

SUBTYPE: VALUE 
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This must reference a valid Customer Premises Type.  Customer Premises Types can 

be found in the Supervisor Workstation under Maintenance > Setup > Subtypes.  

Note that ‘0’ always implies a residential customer type regardless of its description. 

 

MSTID: CODE(12): OPTIONAL 

 

If supplied, this must reference a valid master customer’s Customer ID.  It can also 

point to itself (CONTID = MSTID) signifying that this customer is a master customer.  

Alarm handling distribution and On Test entries are grouped by master customer. 

 

USEMASTER: YES/NO: OPTIONAL. 

 

The Use Master indicator is for future use.  Leave blank. 

 

ACCTYPE: VALUE:  OPTIONAL: 

 

This is the customer account type: (0=Normal Account, 1=Main Account, 2=Sub-

Account, 20=System Account). 

 

CROSSSTREET: STRING(35): OPTIONAL 

 

The cross street of the customer.  

 

SUBDIVISION: STRING(35): OPTIONAL 

 

The subdivision name for the customer.  

 

CMPYID: CODE(12): OPTIONAL: 

 

If supplied, this must reference a valid Accounting Company ID in the receiving 

Manitou database with an Interface Type of ‘Not Interfaced’.  Both CMPYID and 

ACCTID must be supplied or neither (both blank). 

 

ACCTID: CODE(24): OPTIONAL 

 

Both CMPYID and ACCTID must be supplied or neither.  The Accounting Company 

setup may require ACCTID to be unique.  This will be enforced at store time by the 

Manitou system.  For push-type accounting companies (like Sedona) that allow the 

creation of accounts, provide an asterisk as the first character in the ACCTID string 

to force creation of this account.  Use “* (AUTO)” to have the accounting software 

automatically generate a new Account ID. 

 

MAINID: CODE(12): OPTIONAL 

 

If supplied, this must reference a valid main customer’s Customer ID (ACCTYPE is1).  

This field is required and only valid when ACCTYPE is 2 (Sub-Account). 
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TEMPNO: VALUE 

 

 

AGENCY (1004) 

 

CONTID must be unique. 

 

CONTID: CODE(12) 

 

This specifies the new agency’s Agency ID. 

 

FULLNAME: STRING(50) 

 

FILEAS: STRING(50): OPTIONAL 

 

TIMEFMT: VALUE: OPTIONAL 

 

COUNTRY: VALUE 

 

LOCALE: CODE(5) 

 

TIMEZONE: CODE(15) 

 

SUBTYPE: VALUE: OPTIONAL 

 

This must reference a valid Agency Type.  These are found in the Supervisor 

Workstation under Maintenance > Setup > Subtypes. 

 

DISPCODE: CODE(25): OPTIONAL 

 

This is the Dispatch Charge Code field. 

 

QUESTION: STRING(100): OPTIONAL 

 

This is the question to be asked as an alternate form of verification. 

ANSWER: STRING(50): OPTIONAL 

 

This is the expected answer to the above verification question. 

 

AUTHORITY 

 

CONTID must be unique. 
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CONTID: CODE(12) 

 

This specifies the new authority’s Authority ID. 

 

FULLNAME: STRING(50) 

 

FILEAS: STRING(50): OPTIONAL 

 

 

TIMEFMT: VALUE: OPTIONAL 

 

COUNTRY: VALUE 

 

LOCALE: CODE(5) 

 

TIMEZONE: CODE(15) 

 

SUBTYPE: VALUE 

 

This is the type of authority.  The possible values are 0=Police, 1=Fire, 2=Medical. 

 

DISPCODE: CODE(25): OPTIONAL 

 

This is the Dispatch Charge Code field. 

 

PERMITREQD: YES/NO: OPTIONAL 

 

This indicates whether customer permits are required. 

 

FALSELMT: VALUE: OPTIONAL 

 

This is the number of false alarms that will be allowed before fees or suspension of 

service. 

 

FALSETYPE: VALUE: OPTIONAL 

 

This is the type of false alarm period: (0=Sliding Window, 1=Calendar Period, 

2=Forever - never resets). 

 

FALSEPER: VALUE: OPTIONAL  

 

This is the width of the sliding window (days) or calendar period (months). 

 

FALSEMNTH: VALUE: OPTIONAL 
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This is the starting calendar month when FALSETYPE is 1 (Calendar Period). 

PSAPID: VALUE: OPTIONAL 

OSIID: STRING: OPTIONAL 

 

BRANCH (1008) 

 

CONTID must be unique. 

 

CONTID: CODE(12) 

 

This specifies the new branch’s Branch ID. 

 

FULLNAME: STRING(50) 

 

FILEAS: STRING(50): OPTIONAL 

 

TIMEFMT: VALUE: OPTIONAL 

 

COUNTRY: VALUE 

 

LOCALE: CODE(5) 

 

TIMEZONE: CODE(15)  

 

INSTALLER (1024) 

 

The INSTALLER record refers to Dealers.  CONTID must be unique. 

 

CONTID: CODE(12) 

 

This specifies the new dealer’s Dealer ID and must be unique for all dealers in the 

receiving Manitou database. 

 

FULLNAME: STRING(50) 

 

FILEAS: STRING(50): OPTIONAL 

 

TIMEFMT: VALUE: OPTIONAL 

 

COUNTRY: VALUE 

 

LOCALE: CODE(5) 
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TIMEZONE: CODE(15) 

 

MSTID: CODE(12): OPTIONAL 

 

If supplied, this must reference a valid master dealer’s Dealer ID. 

 

USEMASTER: YES/NO: OPTIONAL 

 

This field indicates if a sub-dealer should show its master’s information on an alarm 

screen.  MSTID must be specified to have any effect. 

 

MONGRP: VALUE: OPTIONAL 

 

This is the optionally licensed Monitoring Group to be used for the dealer’s 

customer’s alarm activity, if not already directed to a specific monitoring group.  A 

value of 0 is the default monitoring group – no override.  

 

MONSTATUS: VALUE: OPTIONAL 

 

This is the Monitoring Status of the Dealer (0=Normal, 1=Inactive). Please note that 

if this is set to Inactive, alarm monitoring will be stopped for all of this dealer’s 

customers as if each Active customer was set to Inactive. 

 

CMPYID: CODE(12): OPTIONAL 

 

Accounting Company for Dealer Billing. 

 

ACCTID: CODE(24): OPTIONAL 

 

Accounting Company for Dealer Billing.  For push-type accounting companies (like 

Sedona) that allow the creation of accounts, provide an asterisk as the first 

character in the ACCTID string to force creation of this account.  Use “* (AUTO)” to 

have the accounting software automatically generate a new Account ID. 

 

CMPYID2: CODE(12): OPTIONAL 

 

Accounting Company for Third-Party Dealer Billing.  If using both CMPYID and 

CMPYID2, they should be different. 

 

ACCTID2: CODE(24): OPTIONAL 

 

Account Number for Third Party Dealer Billing.  For push-type accounting 

companies (like Sedona) that allow the creation of accounts, provide an asterisk as 

the first character in the ACCTID2 string to force creation of this account.  Use “* 

(AUTO)” to have the accounting software automatically generate a new Account ID. 
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CUSTOOS: YES/NO: OPTIONAL 

 

This indicates whether customers are allowed to put their own system on test. 

 

ENGSEC: VALUE: OPTIONAL  

 

This is the Technician security modifier: (0=Monitoring Company Level – normal, 

1=Prefix Required).  If set to 1, a periodically changing value must be given by the 

Technician in addition to their password. 

 

EXTEMAILCP: VALUE: OPTIONAL 

 

Contact point sequence of email address to use when sending emails to this 

installer’s customers(-1=Use global name/email address) 

 
 

 

PERSON (1036) 

 

CONTID must be unique.   

 

CONTID: CODE(12) 

 

NAME: STRING(50) 

 

FILEAS: STRING(50): OPTIONAL 

 

If left blank, the utility will take the last ‘word’ of the NAME and put it at the 

beginning followed by a comma and a space, then the rest of the NAME. 

 

TIMEFMT: VALUE: OPTIONAL 

 

COUNTRY: VALUE 

 

LOCALE: CODE(5) 

 

TIMEZONE: CODE(15) 

 

SUBTYPE: VALUE: OPTIONAL 

 

This must reference a valid Keyholder Type.  Keyholder Types can be found in the 

Supervisor Workstation under Maintenance > Setup > Subtypes. 

 

PASSWD: CODE(25): OPTIONAL 
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This is the password for this person.  

 

VRTID: CODE(12): OPTIONAL 

 

This is the Voice Response system login ID. 

 

WEBID: CODE(12): OPTIONAL 

 

This is the Web (BoldNet) link between the Manitou user and the Web user (not 

necessarily the Web login ID). 

 

SUFFIX: STRING(10): OPTIONAL 

 

This is the person’s name suffix (e.g., ‘Jr.’, ‘Sr.’).  Suggested suffixes are found in the 

Supervisor Workstation under Maintenance > Setup > Subtypes, although any value 

may be imported. 

 

INITIALS: STRING(10): OPTIONAL 

 

This cannot be specified in the client, but is constructed by taking the first letter of 

each of the First Name, Middle Name and Last Name (typically entered by clicking 

the ellipsis next to the Name field on the Contact List or Keyholder form, or parsed 

from the Name field if entered through an import).   

 

JOBTITLE: STRING(35): OPTIONAL 

 

This is the person’s Job Title. 

 

SALUTATION: STRING(10): OPTIONAL 

 

This is the person’s title or salutation (e.g., ‘Mr.’, ‘Mrs.’).  Suggested suffixes are 

found in the Supervisor Workstation under Maintenance > Setup > Subtypes, 

although any value may be imported. 

 

QUESTION: STRING(100): OPTIONAL 

 

This is the question to be asked as an alternate form of verification. 

 

ANSWER: STRING(50): OPTIONAL 

 

This is the expected answer to the above verification question. 

 

INACTDATEFRM: DATE: OPTIONAL 
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This is the start of this person’s inactive period.  This can be left empty even if 

INACTDATETO is specified. 

 

INACTDATETO: DATE: OPTIONAL 

 

This is the end of this person’s inactive period.  This can be left empty even if 

INACTDATEFRM is specified. 

 

VALDATEFROM: DATE: OPTIONAL 

 

This is the start of this person’s valid period.  This can be left empty even if 

VALDATETO is specified. 

 

VALDATETO: DATE: OPTIONAL 

 

This is the end of this person’s valid period.  This can be left empty even if 

VALDATEFRM is specified. 

 

DOB: DATETIME: OPTIONAL 

 

This is the Birthday (only month and day are shown – it is recommended that the 

year be 2000 since it allows leap day). 

 

NOTES: LONGTEXT: OPTIONAL 

 

This is any notes or information of interest regarding this person. 

 

CONTID Notes 

 

In the remaining record definitions, CONTID typically refers to the ID of the entity under 

which the particular record is to be created.  DESCR typically applies to the particular 

record being entered. Similarly, CONTTYPE typically refers to the contact type of the entity 

under which the record is to be created (0 = monitoring company, 1 = customer, 2 = 

installer/dealer, 3 = branch, 4 = agency, 5 = authority, 100 = person).  The remainder of the 

records may or may not share common criteria; items with common criteria will be noted 

as they arise.   

 

AC_SECTOR (1000) 

 

AC_SECTOR corresponds to the Sectors item under an Access Control system specified on 

the Systems form.  CONTID + SYSNO must be unique. 

 

CONTID: CODE(12): 
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This must reference a valid customer. 

 

SYSNO: VALUE 

 

Must reference a valid CUSTSYS record for the above customer. 

 

SECTOR: CODE(5) 

 

DESCR: STRING(35)  

 

 

ACTIONS (1001) 

 

ACTIONS corresponds with the list of the action patterns that display in the main portion of 

the Action Patterns.  CONTTYPE + CONTID + ACTIONS must be unique. 

 

CONTTYPE: VALUE: (0, 1, 2) 

 

CONTID: CODE(12) 

 

CONTTYPE + CONTID must reference a valid entity. 

 

ACTIONS: CODE(8) 

 

Only one occurrence of the same actions code is allowed per entity.  

 

DESCR: STRING(35) 

 

This is the action pattern description.  

 

FIRSTAUTO: YES/NO: OPTIONAL 

 

Should the Action Pattern Auto run first 

 

CATEGORY: VALUE: OPTIONAL 

 

Action Pattern Catecory 

 

AUTORUN: YES/NO: OPTIONAL 

 

Should the action pattern use Auto Run 
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ACTIONS_D (1002) 

 

ACTIONS_D corresponds with the actual details of the action pattern that display in the 

Action Patterns form for an entity. 

 

CONTTYPE: VALUE 

 

CONTID: CODE(12) 

 

CONTTYPE + CONTID must reference a valid entity. 

 

ACTIONS: CODE(8) 

 

CONTTYPE + CONTID  + ACTIONS must reference a valid action pattern header for 

this entity. 

 

CMDTYPE: VALUE 

 

QUAL1: VALUE: OPTIONAL 

 

QUAL2: CODE(12): OPTIONAL 

 

CONTID when QUAL2 represents a Serial Number 

 

QUAL2a: STRING(50): OPTIONAL 

 

PERSONNAME when QUAL2 represents a Serial Number for Local Person 

 

QUAL2a: STRING(50): OPTIONAL 

 

PERSONREFID when QUAL2 represents a Serial Number for Local Person 

 

QUAL3: VALUE: OPTIONAL 

 

QUAL4: VALUE: OPTIONAL 

 

QUAL4a: CODE(20): OPTIONAL 

 

QUAL5: VALUE: OPTIONAL 

 

QUAL6: VALUE: OPTIONAL 
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QUAL7: CODE(12): OPTIONAL 

 

CONTID when QUAL7 represents a sub-Serial Number 

 

QUAL7a: STRING(50): OPTIONAL 

 

PERSONNAME when QUAL7 represents a sub-Serial Number for a Local Person 

 

QUAL7b: STRING(50): OPTIONAL 

 

PERSONREFID when QUAL7 represents a sub-Serial Number for a Local Person 

 

QUAL8: VALUE: OPTIONAL 

 

QUAL9: CODE(4): OPTIONAL 

 

QUAL10: STRING(35): OPTIONAL 

 

QUAL11: STRING(255): OPTIONAL 

 

QUAL12: VALUE: OPTIONAL 

 

QUAL13: VALUE: OPTIONAL 

 

 

ADDRESS (1003) 

An example of an ADDRESS string is represented by the following: 

// Address 

1003,1,"SIUTEST0002","","",0,"Address 1 for SIU test 0001 

012345678901234567890","Address 2 for SIU test 0001 

012345678901234567890","Address 3 for SIU test 0001 

012345678901234567890","Address 4 for SIU test 0001 

012345678901234567890","Kenosha","WI","53142","ADDRESS 

1",1,"40.12345678901234,-74.12345678901234",,"","","","","","" 

 

This record includes all information necessary to create city record if necessary.  

ADDRTYPE applies only to local PERSONs; all other entities set this to 0, except in the case 

of alternate addresses, in which case this is used like a sequence number.  MAILADDR 

applies only to PERSONs.  The PERSONNAME/PERSONREFID combination is used only to 

uniquely identify local persons.  If PERSONNAME/PERSONREFID is present, CONTTYPE 

and CONTID refer to the entity to which this person belongs.  PERSONNAME is a foreign 

key to FULLNAME in CONTACT.  CONTTYPE + CONTID + PERSONNAME + PERSONREFID + 

ADDRTYPE must be unique. 

 



Bold Technologies | Data Record Numeric Codes 25 

 

CONTTYPE: VALUE 

 

CONTID: CODE(12) 

 

CONTTYPE + CONTID must reference a valid entity. 

 

PERSONNAME: STRING(50): OPTIONAL 

 

If supplied, PERSONNAME + PERSONREFID must reference a valid local person of 

the above entity. 

 

PERSONREFID: STRING(50): OPTIONAL 

 

If supplied, PERSONNAME + PERSONREFID must reference a valid local person of 

the above entity. 

 

GPSLOC: STRING(40): OPTIONAL 

 

GPS Location (UPPERCASE) 

 

ADDRTYPE: VALUE: OPTIONAL 

 

The ADDRTYPE must reference a valid Address Type.  These are found in the 

Supervisor Workstation under Maintenance > Setup > Subtypes.  For non-person 

entities, this must be 0 or blank (only one site address allowed).  Only one address 

of the same Address Type is allowed per person. 

 

ADDR1: STRING(50) 

 

Address line 1. 

 

ADDR2: STRING(50): OPTIONAL 

 

Address line 2. 

 

ADDR3: STRING(50): OPTIONAL 

 

Address line 3. 

 

ADDR4: STRING(50): OPTIONAL 

 

Address line 4. 

 

CITYNAME: STRING(50) 

  

Must reference an existing city in the receiving Manitou database 
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REGIONNAME: CODE(35) 

  

The region name corresponds to the FILEAS column of an existing state or province 

in the receiving Manitou database. Regions can be edited in the Supervisor 

Workstation under Maintenance > Setup > Country Setup. 

 

POSTCODE: STRING(15) 

 

STREET: STRING(50): OPTIONAL 

 

Address line 2. 

 

COUNTRY: VALUE 

 

Must reference an existing country in the receiving Manitou database 

 

GPSLOC: STRING(40) 

 

Address line 2. 

 

MAILADDR: YES/NO: OPTIONAL 

 

Leave Empty or set to 0 unless the record of a local persons 

 

NUMBER: STRING(12): OPTIONAL 

 

NAME: STRING(50): OPTIONAL 

 

TYPE: STRING(10): OPTIONAL 

 

POSTDIR: STRING(2): OPTIONAL 

 

UNIT: STRING(20): OPTIONAL 

 

 

 

 

 

ALTCONTACT (1005) 

 

CONTTYPE: VALUE 

 

CONTID: CODE(12) 
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CONTTYPE + CONTID must reference a valid entity. 

 

FULLNAME: STRING(50) 

 

 

ATTN (1006) 

 

ATTN is found in the Attentions form of an entity.  This does not apply to persons.  

CONTTYPE + CONTID + ATTNTYPE must be unique. 

 

CONTTYPE: VALUE: (0, 1, 2, 3, 4, 5) 

 

CONTID: CODE(12) 

 

CONTTYPE + CONTID must reference a valid entity. 

 

ATTNTYPE: VALUE 

 

The ATTNTYPE must reference a valid Attention Type.  These are found in the 

Supervisor Workstation under Maintenance > Setup > Subtypes.  For non-person 

entities, this must be 0 or blank (only one site address allowed).  Only one attention 

entry of the same type is allowed per entity. 

 

REFCONTID: CODE(12) : OPTIONAL 

 

This must reference a valid contact entity of the main entity’s contact list.  Either 

REFCONTID or PERSONNAME must be supplied. 

 

PERSONNAME: STRING(50) : OPTIONAL 

 

This, along with PERSONREFID, must reference a valid local person of the main 

entity’s contact list.  Either REFCONTID or PERSONNAME/PERSONREFID must be 

supplied. 

 

PERSONREFID: STRING(50) : OPTIONAL 

 

This, along with PERSONNAME, must reference a valid local person of the main 

entity’s contact list.  Either REFCONTID or PERSONNAME/PERSONREFID must be 

supplied. 

 

 

CALLLIST (1009) 
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CALLLIST is the list of call lists in the Call Lists form for an entity. It is also the basic 

information presented in the upper section of the Call Lists form.  CONTTYPE + CONTID + 

CALLLIST must be unique. 

 

CONTTYPE: VALUE: (0, 1, 2, 3, 4, 5) 

 

CONTID: CODE(12) 

 

CONTTYPE + CONTID must reference a valid entity. 

 

CALLLIST: CODE(4) 

 

This is the call list code.  Only one call-list entry of the same code is allowed per 

entity. 

 

DESCR: STRING(35) 

 

This is the call list description. 

 

CLEVEL: VALUE: OPTIONAL 

 

This is the Call List type (0=Main, 1=Sub List).  A sub-list can be referenced 

(included) by a main list, and can also be used stand-alone. 

 

ROTATEACT: YES/NO: OPTIONAL 

 

This indicates whether this call list has a rotation schedule.  Only lists that contain 

only persons may rotate. 

 

ROTATEINT: VALUE: OPTIONAL 

 

This is the interval (in days) at which a rotating call list will be rotated. 

 

ROTATENXT: DATETIME: OPTIONAL 

 

This is when the next rotation will occur (date and time). 

 

ROTATECONTID: CODE(12) : OPTIONAL 

 

If supplied, this must reference a valid global keyholder entity of this call list.  For 

rotating call lists, either ROTATECONTID or PERSONNAME must be used to point to 

the current head of the rotating list. 

 

PERSONNAME: STRING(50) : OPTIONAL 
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If supplied, this, along with PERSONREFID must reference a valid local person of 

this call list.  For rotating call lists, either ROTATECONTID or 

PERSONNAME/PERSONREFID in addition to ROTATECPTYPENO or 

ROTATETYPETXT must be used to point to the current head of the rotating list. 

 

PERSONREFID: STRING(50) : OPTIONAL 

 

If supplied, this, along with PERSONNAME, must reference a valid local person of 

this call list.  For rotating call lists, either ROTATECONTID or 

PERSONNAME/PERSONREFID in addition to ROTATECPTYPENO or 

ROTATETYPETXT must be used to point to the current head of the rotating list. 

 

ROTATECPTYPENO: INTEGER : OPTIONAL 

 

Used for pointing to the head of a rotating call list. ROTATECONTID or 

PERSONNAME/PERSONREFID in addition to ROTATECPTYPENO or 

ROTATETYPETXT must be used to point to the current head of the rotating list. 

 

ROTATETYPETXT: STRING(20) : OPTIONAL 

 

Used for pointing to the head of a rotating call list. ROTATECONTID or 

PERSONNAME/PERSONREFID in addition to ROTATECPTYPENO or 

ROTATETYPETXT must be used to point to the current head of the rotating list. 

 

CALLSCHED: CODE(4) : OPTIONAL 

 

This is the general schedule that can be applied to this call list.  It can be used to 

control when the list is valid.  If supplied, this must reference a valid ‘Call List 

Availability’ general schedule for this entity. 

 

DEFERLIST: CODE(4) : OPTIONAL 

 

If a CALLSCHED has been specified, this field can be used to redirect to a different 

call list should the schedule indicate that this list is ‘out of schedule’.  

 

 

CALLLIST_D (1010) 

 

Notes: REFCONTTYPE/REFCONTID and PERSONNAME/PERSONREFID are used in two 

ways: (1) to locate a contact in the contact list to get the LISTSEQ number, and (2) to locate 

an appropriate SUBLIST.  REFCONTTYPE and either REFCONTID or 

PERSONNAME/PERSONREFID are required unless SUBLIST is given, in which case only 

REFCONTID may be given or not.  If SUBLIST is given and no reference contact is given, 
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LISTSEQ and CPTYPENO should be set to -1.  PERSONNAME/PERSONREFID is used only for 

local persons in which case REFCONTTYPE must be 100 and REFCONTID is null. 

 

This record corresponds primarily with the actual contact list.  CONTTYPE + CONTID + 

CALLLIST + REFCONTTYPE + REFCONTID + PERSONNAME + PERSONREFID + CPTYPENO 

+ TYPETXT must be unique. 

 

CONTTYPE: VALUE 

 

CONTID: CODE(12) 

 

CONTTYPE + CONTID must reference a valid entity. 

 

CALLLIST: CODE(4) 

 

CONTTYPE + CONTID + CALLLIST must reference a valid call list header for this 

entity. 

 

SEQ: VALUE 

 

This field identifies the order position of the call list entry and must be supplied 

 

REFCONTTYPE: VALUE: (0, 1, 2, 3, 4, 5, 100): OPTIONAL 

 

This field identifies the contact type of a contact to be referenced by REFCONTID 

below. 

 

REFCONTID: CODE(12): OPTIONAL 

 

This must reference a valid contact entity of the main entity’s contact list.  Either 

REFCONTTYPE/REFCONTID or PERSONNAME must be supplied. 

 

PERSONNAME: STRING(50): OPTIONAL 

 

This, along with PERSONREFID, must reference a valid local person of the main 

entity’s contact list.  Either REFCONTTYPE/REFCONTID or 

PERSONNAME/PERSONREFID must be supplied. 

 

PERSONREFID: STRING(50): OPTIONAL 

 

This, along with PERSONNAME, must reference a valid local person of the main 

entity’s contact list.  Either REFCONTTYPE/REFCONTID or 

PERSONNAME/PERSONREFID must be supplied. 

 

CPTYPENO: VALUE: OPTIONAL 
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If specified, this must reference a valid Contact Point Type of the above contact 

(identified by either REFCONTID or PERSONNAME). The Contact Point Types can be 

found in the Supervisor Workstation under Maintenance > Setup > Contact Point 

Types. 

 

TYPETXT: STRING(20): OPTIONAL 

 

If specified, this must reference the description of a valid Contact Point Type to 

contact. The Contact Point Types can be found in the Supervisor Workstation under 

Maintenance > Setup > Contact Point Types. 

 

MUSTCNTCT: YES/NO: OPTIONAL 

 

This indicates whether this contact must be contacted whether or not anyone else 

on the list has also been contacted. 

 

NOROTATE: YES/NO: OPTIONAL 

 

This indicates whether this contact rotates or not and applies only when a rotating 

list has been specified.  Non-rotating persons will always appear at the bottom of the 

call list when presented to an operator. 

 

SUBLIST: CODE(4): OPTIONAL 

 

If supplied, this must reference a valid Sub-List of entity 

REFCONTTYPE/REFCONTID.  SUBLIST cannot be specified for a sub-list.  Only main 

lists can contain sub-lists. Either REFCONTID, PERSONNAME/PERSONREFID or 

SUBLIST must be supplied. 

 

CLOG (1011) 

 

See below. 

 

COMMENTS (1012) 

 

COMMENTS for entities (not persons). 

 

CONTTYPE: VALUE: (0, 1, 2, 3, 4, 5) 

 

CONTID: CODE(12) 

 

CONTTYPE + CONTID must reference a valid entity (not including persons). 

 

COMMENTTYPE: VALUE 
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This is the type of comment being imported (0=Temporary, 1=Standing, 2=Special 

Instructions, 100=In-house Comments – dealer only). 

 

DESCR: STRING(35) 

 

This is the description of the comment/instruction.  For Special Instructions, this 

description must reference a Monitoring Company Special Instruction description (not case 

sensitive) and all other fields below will be ignored. 

 

VALDATEFRM: DATETIME: OPTIONAL 

 

VALDATETO: DATETIME: OPTIONAL 

 

FOLLOWUP: DATETIME: OPTIONAL 

 

This is valid for temporary comments only. 

 

PRIORITY: VALUE:  OPTIONAL 

 

This value determines the order in which comments of a given type are displayed for a 

given entity. 

 

ALERT: VALUE: OPTIONAL 

 

This value determines when this comment will be shown to a user depending upon the 

context (Bitmask: 0x01=Alarm, 0x02=On Test, 0x04=Pre-Cancel, 0x08=Entity Maintenance, 

0x10=Paged Contacts, 0x20=Temporary Comments, 0x40=Temporary Schedules). 

 

MUSTSEE: YES/NO: OPTIONAL 

 

This determines whether the comment must be seen by a user when found for an alarm. 

The above ALERT field must have the ‘Alarm’ value (ALERT bit-and 1 = 1). If the ‘Alarm’ 

value is set, the alarm will not be eligible for auto-client processing (initial handling must 

start with a user).  

 

COMMENTS: LONGTEXT: OPTIONAL 

 

SECURITY: VALUE: OPTIONAL 

 

THREAT: VALUE: OPTIONAL 

 

 

 

CONTLIST (1013) 

 

Notes: The PERSONNAME/PERSONREFID combination is used only for local persons.  To 

add a local person, use CONTLIST. However, users may add other data to a local person 
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using the appropriate section. For example, to add an address to a local person, use the 

ADDRESS section and fill in the appropriate fields required for adding an address to a local 

person.  If PERSONNAME/PERSONREFID is present, CONTTYPE and CONTID refer to the 

entity to which this person belongs, and REFCONTID must be empty.   

 

AUTHCONTPOINT is used to look up an existing Authority, and must be a properly 

formatted telephone number.  If an appropriate Authority matching this contact point 

cannot be found, a new Authority will be created and added to the main entity.  

 

CONTLIST corresponds to items found in the Contact Information tab, which is located in 

the Contact List form. Some items, such as Title, Suffix, Job, Birthday, etc. are stored in the 

PERSON record for an individual.  

 

CONTTYPE + CONTID + REFCONTTYPE + REFCONTID + PERSONNAME + PERSONREFID 

must be unique. 

 

CONTTYPE: VALUE: (0, 1, 2, 3, 4, 5) 

 

CONTID: CODE(12) 

 

CONTTYPE + CONTID must reference a valid entity (not including persons). 

 

REFCONTTYPE: VALUE: (0, 1, 2, 3, 4, 5, 100) 

 

This is the Contact Type of the contact. 

 

REFCONTID: CODE(12): OPTIONAL 

 

 

REFCONTTYPE/REFCONTID must reference a valid entity.  Either REFCONTID or 

PERSONNAME/PERSONREFID must be specified, but not both. 

 

PERSONNAME: STRING(50): OPTIONAL 

 

REFCONTTYPE/PERSONNAME/PERSONREFID must reference a valid local person 

of this entity.  REFCONTTYPE must be 100 for person if 

PERSONNAME/PERSONREFID is supplied.  Either REFCONTID or 

PERSONNAME/PERSONREFID must be specified, but not both. 

 

PERSONREFID: STRING(50): OPTIONAL 

 

A name to give a local person that, together with PERSONNAME, can be used in 

other record types to refer to this local person. 

 

AUTHCONTPOINT: STRING(50): OPTIONAL 
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Only applicable to references of contact type AUTHORITY 

 

SUBTYPE: VALUE: OPTIONAL 

 

If supplied, this must reference a valid SUBTYPE for the given REFCONTTYPE.  For 

Authorities, the only allowed values are 0=Police, 1=Fire, 2=Medical and is not 

optional. 

 

DISPSEQ: VALUE: OPTIONAL 

 

This determines the order in which contacts are displayed in the contact list for an 

alarm. If not supplied, or multiple entries have the same DISPSEQ, the contact list 

order will prevail. 

 

ACCESS: CODE(30): OPTIONAL 

 

This is a list of characters that specify difference access permissions given to this 

contact.  This field must be empty for Authority, Installer, Branch, and Customer – 

only applies to Person and Agency contact types.  The possible characters are: 

A=Can Open/Close, C=Can Open/Close anytime, B=Can authorize a schedule change, 

D=Can put system on test, E=Can put designated area on test, F=Can cancel alarm, 

G=Can edit customer record, H=Can give out customer information, I=Can 

temporarily open, X=On Stop. 

 

PASSWD: CODE(25) : OPTIONAL 

 

This is valid for Person and Agency contact types only. 

 

PROFNO: VALUE: OPTIONAL  

 

This field, if supplied, must reference a valid Web profile and is only applicable to 

Person contact types with a PASSWD and a WEBID.  Profiles can be edited in the 

Supervisor Workstation under Maintenance > Setup >Permissions, and expanding 

the Web Client Permissions tree. 

 

NOMINSTEST: VALUE: OPTIONAL 

 

For Person contact types with either a PASSWD and either a WEBID or a VRTID (or 

both), this field determines the maximum time allowed in minutes of an On Test 

event initiated by this person via the Web or VRT applications. 

 

NOMINSOPEN: VALUE: OPTIONAL 

 

For Person or Agency contact types, this field determines the time in minutes of an 

allowed temporary open window.  This ACCESS attribute ‘I’ must also be specified. 

 



Bold Technologies | Data Record Numeric Codes 35 

 

INACTDATEFRM: DATETIME: OPTIONAL 

 

INACTDATETO: DATETIME: OPTIONAL 

 

VALDATEFROM: DATETIME: OPTIONAL 

 

VALDATETO: DATETIME: OPTIONAL 

 

SUPPRESS: YES/NO: OPTIONAL 

 

If this field is a ‘Yes’, then it will not be shown on the full contact list display of an 

alarm. 

 

PERSON_DOB: DATE: OPTIONAL 

 

Local person’s date of birth. 

 

PERSON_VRTID: CODE(12): OPTIONAL 

 

Local person’s VRT ID. 

 

PERSON_WEBID: CODE(12): OPTIONAL 

 

Local person’s Web ID. 

 

PERSON_SUFFIX: STRING(10): OPTIONAL 

 

Local person’s suffix (e.g. “Jr.”). 

 

PERSON_JOBTITLE: STRING(35): OPTIONAL 

 

Local person’s job title. 

 

PERSON_SALUTATION: STRING(10): OPTIONAL 

 

Local person’s salutation (e.g. “Mr.”). 

 

PERSON_QUESTION: STRING(100): OPTIONAL 

 

Local person’s security question. 

 

PERSON_ANSWER: STRING(50): OPTIONAL 

 

Local person’s answer to security question. 

 

NOTES: LONGTEXT: OPTIONAL 
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VALIDATED: YES/NO: OPTIONAL 

 

 

 

CONTLIST_D (1014) 

 

CONTLIST_D corresponds to the specific access permissions for an item in the CONTLIST. 

Though contacts in a customer will have every System and Area listed in the USER ID tab, 

only areas to be allowed will need an entry in the CONTLIST_D. 

 

Notes: SEQ is automatically generated at insertion time, and LISTSEQ is recovered from 

corresponding CONTLIST record. PANUSRID requires AREA (which may be "*") 

 

CONTTYPE: VALUE 

 

CONTID: CODE(12) 

 

CONTTYPE + CONTID must reference a valid entity. 

 

REFCONTTYPE: VALUE 

 

REFCONTID: CODE(12) : OPTIONAL 

  

REFCONTTYPE / REFCONTID must reference a valid Person or Agency CONTLIST entry for 

this entity.  Either REFCONTID or PERSONNAME must be specified, but not both. 

 

PERSONNAME: STRING(50): OPTIONAL 

 

 

REFCONTTYPE/PERSONNAME/PERSONREFID must reference a valid local person 

entry of this entity.  REFCONTTYPE must be 100 for person if 

PERSONNAME/PERSONREFID is supplied.  Either REFCONTID or 

PERSONNAME/PERSONREFID must be specified, but not both. 

 

PERSONREFID: STRING(50): OPTIONAL 

 

REFCONTTYPE/PERSONNAME/PERSONREFID must reference a valid local person 

entry of this entity.  REFCONTTYPE must be 100 for person if 

PERSONNAME/PERSONREFID is supplied.  Either REFCONTID or 

PERSONNAME/PERSONREFID must be specified, but not both. 

 

SYSNO: VALUE 

 

This must reference a valid system number for this entity. 
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AREA: CODE(4) 

 

This is the area designation that this Person/Agency will be allowed to access and  

must reference a valid area for the above system number or ‘*’ to indicate all areas 

of the system. 

 

PANUSRID: CODE(12): OPTIONAL 

 

This specifies the Panel User ID for the Person/Agency for the above Area and 

system.  If AREA is ‘*’, then this Panel User ID applies to all areas of the system.  

Specific Area/Panel User ID access can be specified including specific area overrides 

of the ‘all’ areas entry.  

 

CONTPOINT (1015) 

 

CONTPOINT corresponds to the various contact points found in the Contact Details tab in 

the Contact List form for an entity. 

 

CONTTYPE: VALUE: (0, 1, 2, 3, 4, 5, 100) 

 

CONTID: CODE(12) 

  

If supplied, CONTTYPE + CONTID must reference a valid entity. 

 

PERSONNAME: STRING(50): OPTIONAL 

 

If supplied, CONTTYPE/PERSONNAME/PERSONREFID must reference a valid local 

person by name. 

 

PERSONREFID: STRING(50): OPTIONAL 

 

If supplied, CONTTYPE/PERSONNAME/PERSONREFID must reference a valid local 

person by name. 

 

DISPSEQ: VALUE 

 

This determines the order in which contact points are displayed.  If not supplied, or 

multiple entries have the same DISPSEQ, the contact point list order will prevail. 

 

CPTYPENO: VALUE: OPTIONAL 

 

This must reference a valid Contact Point Type and is mutually exclusive of 

TYPETXT. 
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TYPETXT: STRING(20): OPTIONAL 

 

This must reference a valid Contact Point Type by description and is mutually 

exclusive of CPTYPENO.  Contact Point Types can be found in the Supervisor 

Workstation under Maintenance > Setup > Contact Point Types. 

 

CONTPOINT: STRING(50) : OPTIONAL 

 

The format depends upon the Contact Point Type which will indicate a phone 

number, pager number, fax number, retransmission address, email address or web 

address. 

 
FILEAS: STRING(50): OPTIONAL 

 

HIDDEN: YES/NO: OPTIONAL 

 

This is indicates whether the Contact Point information is "Private" and should be 

hidden from general view. 

 

DOCTYPE: VALUE: OPTIONAL 

 

For email Contact Point Types, this specifies the document output type:  0=PDF, 

1=RTF. 

 

OUTDEVCDE: CODE(12): OPTIONAL 

 

This is the Output Device Type for this Contact Point and applies to pager, 

retransmission and email Contact Point Types.  If supplied, this must reference a 

valid Output Device Type.  Output Device Types can be found in Supervisor 

Workstation under Maintenance > Setup > Output Device Types. 

 

SVCECDE: CODE(12): OPTIONAL 

 

If supplied, this must reference a valid Service Provider Device code. Not all Output 

Device Types require a Service Provider Device code.  Service Provider Devices can 

be found in Supervisor Workstation under Maintenance > Setup > Service Provider 

Devices. 

 

PAGERNO: CODE(10): OPTIONAL 

 

This field specifies the extension number if the Contact Point Type is ‘Phone 

Number’ (non-pager) or the Pager Access Code if the Contact Point Type is ‘Pager’. 

 

SCHEDNO: CODE(4): OPTIONAL 
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If supplied, this must reference a valid ‘Keyholder Availability’ general schedule of 

the contact. 

 

SCRIPTNO: VALUE: OPTIONAL:  

 

If supplied, this must reference a valid Script Message number.  This is valid for all 

contact types other than ‘Web’. 

 

COUNTRY: VALUE 

 

This is the country to be used for formatting phone numbers and determining 

country access codes.  This must reference a valid country in the receiving Manitou 

database. 

 

 

CUSTOPTIONS (1017) 

An example of a CUSTOPTIONS string is represented by the following:  

// Custoptions 

1017,"SIUTEST0002","11/01/2014",1,"","GRPCD","Generic group code 

description12345","CLS","Generic class code description12345",0,,"","",,0,0,0,0,1,2, 

 

CUSTOPTIONS corresponds to options for a customer, both in the Options form as well as 

other places in Customer Maintenance. 

 

Notes: GRPCODE and CLASSCODE can be automatically inserted into the database upon 

import if the appropriate options are turned on in the Standard Import Utility.  If they are 

turned on, the utility will attempt to find the code in the database using the GRPCODE or 

CLASSCODE.  If this fails, it will attempt to use the GRPCODEDESCR or CLASSCODEDESCR, 

but only if they are given.  If this fails, the utility will automatically insert a new GRPCODE 

or CLASSCODE record in the database at import time.  CONTID must be unique. 

 

CONTID: CODE(12) 

 

This must reference a valid customer. 

 

STARTDATE: DATE: OPTIONAL 

 

This item corresponds to the date the system was first started.  

 

COMMSTATE: VALUE: OPTIONAL 

 

This is the commission state and can be one of the following values: -1=New 

Customer/Pending, 0=Not Commissioned/Inactive, 1=Commissioned/Active, 

2=Decommissioned/Deactivated. 
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PAGERMSG: LONGTEXT: OPTIONAL 

 

This field contains the Default Script Message for the customer. 

 

GRPCODE: CODE(5) : OPTIONAL 

 

This field, if specified, can reference a valid Group Code or be added as a new Group 

Code if the proper import option is enabled.  Group Codes can be found in 

Supervisor Workstation under Maintenance > Group Codes. 

 

GRPCODEDESCR: STRING(35): OPTIONAL 

 

This field, if specified, can reference a valid Group Code by description.  It can also 

be the new Group Code description if GRPCODE is supplied and the proper import 

option is enabled to create Group Codes. 

 

CLASSCODE: CODE(3) : OPTIONAL 

 

This field, if specified, can reference a valid Class Code or be added as a new Class 

Code if the proper import option is enabled.  Class Codes can be found in Supervisor 

Workstation under Maintenance > Class Codes. 

 

CLASSCODEDESCR: STRING(35): OPTIONAL 

 

This field, if specified, can reference a valid Class Code by description.  It can also be 

the new Class Code description if CLASSCODE is supplied and the proper import 

option is enabled to create Class Codes. 

 

MONGRP: VALUE: OPTIONAL 

 

This is the Monitoring Group value to be applied to all alarms that are not already 

directed to a specific Monitoring Group.  Monitoring Group ‘0’ is the default and 

always allowed.  Monitoring Groups can be found in Supervisor Workstation under 

Maintenance > Setup > Monitoring Groups. 

 

CODE: VALUE: OPTIONAL 

 

This is the delete or deactivation code – user defined. 

 

REASON: STRING(50) : OPTIONAL 

 

This is the delete or deactivation reason comment. 

 

ULGRADE: CODE(12) : OPTIONAL 
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This specifies the UL Grade code.  Default UL Grades can be found in Supervisor 

Workstation under Maintenance > Setup > Subtypes under the UL Grades section.  

Please note that the UL Grade information will not display in the client unless the 

UL Policy Licensed checkbox in the Country Options section found in Maintenance 

> Setup > Country Setup in Supervisor Workstation is checked. 

 

ULRESPTIME: VALUE: OPTIONAL 

 

This is the expected UL Response Time in minutes. 

 

IGNOREABORT: YES/NO: OPTIONAL 

 

AUTOCANC: YES/NO: OPTIONAL 

 

GENUREST: YES/NO: OPTIONAL 

 

SIGSUSR: YES/NO: OPTIONAL 

 

AREAFILL: VALUE: OPTIONAL 

 

This field determines what should happen if a signal is received having an area value 

that does not exist and must be one of the following values: 0=Ignore, 

1=Add/Update Area if System on Test, 2=Add/Update Area Always, 3=Use First 

Area. 

 

ZONEFILL: VALUE: OPTIONAL 

 

This field determines what should happen if a signal is received having an zone 

value that does not exist and must be one of the following values: 0=Ignore, 

1=Add/Update Area if System on Test, 2=Add/Update Area Always. 

 
THREAT: VALUE: OPTIONAL 

  

Current threat level for customer. 

 

 

CUSTPW (1018) 

 

This is the Passwords section of the Options Jump To item in Customer Maintenance 

 

CONTID: CODE(12) 

 

This must reference a valid customer. 
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DESCR: STRING(35) 

 

PASSWD: CODE(25) 

 

DURESS: YES/NO: OPTIONAL 

 

 

CUSTSYS (1019) 

An example CUSTSYS string is represented as follows: 

// Custsys 

1019,"SIUTEST0002",1,"System 1 for SIU test customer 0001",0,1, 

 

This is the Systems form in Customer Maintenance.  CONTID + SYSNO must be unique. 

 

CONTID: CODE(12) 

 

This must reference a valid customer. 

 

SYSNO: VALUE 

 

This field specifies the System Number of the desired system. 

 

DESCR: STRING(35) 

 

SYSTYPE: VALUE 

 

This field specifies the type of system and must be one of the following values: 0 = 

Event Monitoring, 1 = Access Control, 2 = GPS, 3= Other. 

  

MONTYPE: VALUE 

 

This must reference a valid Monitoring Type with an Attribute of ‘M’ if SYSTPYE is 0, 

‘X’ if SYSTPE is 1, ‘G’ if SYSTPYE is 2, or ‘N’ if SYSTPYE is 3 and be of the correct 

Subtype for the referenced customer.  Monitoring Types can be found in Supervisor 

Workstation under Maintenance > Setup > Monitoring Types. 

 

PANELTYPE: CODE(25): OPTIONAL 

 

This must reference a valid Panel Type.  This is only applicable if SYSTYPE is 0.  

Panel Types can be found in Supervisor Workstation under Maintenance > Control 

Panels. 

 

CUSTUFLD (1020) 
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CONTID: CODE(12) 

 

This must reference a valid customer.  CONTID + CUSTFIELDNO must be unique. 

 

CUSTFIELDNO: VALUE 

 

This must reference a valid user defined field number (1-8).  Customer User Defined 

fields are found in Supervisor Workstation under Tools > Options > Account 

Creation/Maintenance > Customer user defined fields.  Open the Field Properties 

dialog to verify the field number. 

 

VALUE: STRING(60): OPTIONAL 

 

This is the data or value for the user defined field.  Its format is determined by the 

field properties of the specific user defined field.  The possible types are Numeric, 

Alpha (text), Upper Case (text), Date, Phone Number, Yes/No. 

 

 

EVENTPRG (1021) 

 

EVENTPRG corresponds to the Event Actions Programming section for a customer system, 

found in the Systems form as well as in the Programming item in the Systems tree. 

 

CONTID: CODE(12) 

 

This must reference a valid customer. 

 

SYSNO: VALUE 

 

This must reference a valid system for the referenced customer and qualifies when 

the supplied Actions code will be applied to alarm signals. 

 

STCODE: CODE(8) 

 

This must reference a valid Event Code.  Event Codes are found in Supervisor 

Workstation under Maintenance > Events > Event Codes and qualifies when the 

supplied Actions code will be applied to alarm signals and may determine default 

values if not supplied here. 

 

COMMSNO: CODE(4) 
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This must reference a valid transmitter for the referenced customer system or be “*” 

which means ‘all’ transmitters and qualifies when the supplied Actions code will be 

applied to alarm signals. 

 

AREA: CODE(4): OPTIONAL 

 

This field qualifies when the supplied Actions code will be applied to alarm signals.  

It must match the area of the signal or can be “*” which will match any area. 

 

ZONE: CODE(5): OPTIONAL 

 

This field qualifies when the supplied Actions code will be applied to alarm signals.  

It must match the zone of the signal or can be “*” which will match any zone or any 

partial match (e.g., “2*” which would match any zone that starts with a ‘2’). 

 

For GPS systems, this specifies the TRACKID for an Asset. 

 

ALARM: VALUE: OPTIONAL 

 

This field determines the behavior of the signal (whether it will be an alarm or not) 

when the signal matches this entry.  The possible values are:  0=No (will not be an 

alarm – value assigned if not supplied), 1=Yes (will be an alarm), 2=Default (use 

alarm setting of the Event Code). 

 

ACTIONMODE: VALUE 

 

ACTIONS: CODE(8): OPTIONAL 

 

This field specifies the action pattern code to execute for matching alarm signals.  

This is optional and if left empty, the default actions code of the Event Code will be 

used. 

 

SIGINST: LONGTEXT: OPTIONAL 

 

This is signal instruction text that will be presented to an alarm handling user for 

matching alarm signals. 

 

 

GENSCHED (1022) 

 

GENSCHED corresponds to an entity’s General Schedules in entity maintenance.  As with 

the ACTIONS, CONTLIST and CALLLIST, the GENSCHED record applies primarily to the 

basic general schedule identification; full details for a given GENSCHED will be defined in 

GENSCHED_D below.  CONTTYPE + CONTID + TYPE + SCHEDNO must be unique. 
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CONTTYPE: VALUE: (0, 1, 2, 3, 4, 5, 100) 

 

CONTID: CODE(12) 

 

CONTTYPE + CONTID must reference a valid entity. 

 

TYPE: VALUE 

 

This field specifies the type of general schedule and must be one of the following:  

0=Keyholder Availability, 1=Programming, 2=On Test, 5=Access Control, 6=Call List 

Availability. Type 1 and 5 are only acceptable for Customers.  Type 2 is only 

acceptable for Agency, Branch and Dealer.  Global Keyholders can only have Type 0. 

 

SCHEDNO: CODE(4) 

 

This specifies the schedule code.   

 

DESCR: STRING(35) 

 

This is the description of the schedule. 

 

WEEKMOD: VALUE: OPTIONAL 

 

This is the modulus number to apply to week number. 

 

INTERVAL: VALUE: OPTIONAL 

 

This is the interval in minutes for Exec Protection. 

 

 

GENSCHED_D (1023) 

 

GENSCHED_D corresponds to specific date and time information within a general schedule. 

 

CONTTYPE: VALUE 

 

CONTID: CODE(12) 

 

CONTTYPE + CONTID must reference a valid entity. 

 

TYPE: VALUE 

 

SCHEDNO: CODE(4) 
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CONTTYPE + CONTID + TYPE + SCHEDNO must reference a valid General Schedule. 

 

MON: YES/NO: OPTIONAL 

 

TUE: YES/NO: OPTIONAL 

 

WED: YES/NO: OPTIONAL 

 

THU: YES/NO: OPTIONAL 

 

FRI: YES/NO: OPTIONAL 

 

SAT: YES/NO: OPTIONAL 

 

SUN: YES/NO: OPTIONAL 

 

TIMES1: TIME: OPTIONAL 

 

All times are to be formatted as HH:mm (no seconds). 

 

TIMEF1: TIME: OPTIONAL 

 

TIMES2: TIME: OPTIONAL 

 

TIMEF2: TIME: OPTIONAL 

 

DATEFRM: DATE: OPTIONAL 

 

If DATEFRM is specified, DATETO must also be supplied. 

 

DATETO: DATE: OPTIONAL 

 

If DATETO is specified, DATEFRM must also be supplied. 

 

 

 

INSTCHG (1025) 

 

INSTCHG is specific to dealers and corresponds with the Billing Charges in the Dealer 

Maintenance form.  CONTTYPE + CONTID + TYPE + ITEMCODE must be unique.   

 

CONTTYPE: VALUE 
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0 for Company-level charges, 2 for Installer-level charges. 

 

CONTID: CODE(12) 

 

If CONTTYPE is 2 (installer), CONTID must reference a valid dealer.  Otherwise, this 

value should be empty. 

 

TYPE: VALUE 

 

This refers to the type of charge.  0 = Recurring, 1 = Add Charges, 2 = Signal 

Overages, 3 = Time Overages. 

 

ITEMCODE: CODE(25)  

 

ITEMCODE refers to either a valid CLASSCODE (limited to 3 characters) or 

BILLCODE (from Monitoring Type of each Monitoring Service) – see Dealer Billing 

system option found in Supervisor Workstation under Tools > Options > System > 

Dealer billing by monitoring service. 

 

BILLCODE: CODE(25): OPTIONAL 

 

RATE1: CODE(5): OPTIONAL 

 

RATE2: CODE(5): OPTIONAL 

 

QUAL1: VALUE: OPTIONAL 

 

For Type of 0: Number of months in cycle (1, 3, 6, or 12) 

For Type of 2: Signal Limit Count 

For Type of 3: Pricing Unit (0 = Seconds, 1 = Minutes) 

 

QUAL2: VALUE: OPTIONAL 

 

For Type of 2: Alarm Limit Count 

For Type of 3: Time Limit Count (Seconds) 

 

QUAL3: VALUE: OPTIONAL 

 

For Type of 2: Total Limit Count 

For Type of 3: Time Increment (Seconds per incident, e.g. 15 second increments) 

 

PRICE1: MONEY: OPTIONAL 

 

For Type of 0: Price for active customers. 

For Type of 1 or 3: Price for the add or time overages. 
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For Type of 2: If PRICE2 is not given, this is the total price to charge; otherwise, it is 

the price for signal overages. 

 

PRICE2: MONEY: OPTIONAL 

 

For Type of 0: Price for inactive customers. 

For Type of 1 or 3: Ignored. 

For Type of 2: Price for alarm overages. 

 

 

INSTCP (1026) 

 

INSTCP corresponds to the Control Panels in the Dealer Maintenance form.  CONTID + 

PANELTYPE must be unique. 

 

CONTID: CODE(12) 

 

CONTID must reference a valid dealer. 

 

PANELTYPE: CODE(25) 

 

This must reference a valid Panel Type code.  Control Panel information can be 

found in Supervisor Workstation under Maintenance > Control Panels. 

 

REMTYPE: VALUE: OPTIONAL 

 

This field refers to the Remote Reset type to be used for this control panel type, 

which is only available in the UK (Country 44) configurations. 

 

SEED: CODE(8): OPTIONAL 

 

This field refers to the Seed Code to be used with the supplied Remote Reset type, 

which is also only available in the UK (Country 44) configurations. 

 

 

INSTEVPRG (1027) 

 

INSTEVPRG corresponds to the Programming form in the Dealer Maintenance form.  It is 

functionally identical to the EVENTPRG record, without Transmitter, Area and Zone 

information.  CONTID + STCODE must be unique. 

 

CONTID: CODE(12) 
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CONTID must reference a valid dealer. 

 

STCODE: CODE(8) 

 

This must reference a valid Event Code.  Event Codes are found in Supervisor 

Workstation under Maintenance > Events > Event Codes and qualifies when the 

supplied Actions code will be applied to alarm signals and may determine default 

values if not supplied here. 

 

ALARM: VALUE: OPTIONAL 

 

This field determines the behavior of the signal (whether it will be an alarm or not) 

when the signal matches this entry.  The possible values are:  0=No (will not be an 

alarm – value assigned if not supplied), 1=Yes (will be an alarm), 2=Default (use 

alarm setting of the Event Code). 

 

ACTIONMODE: VALUE 

 

ACTIONS: CODE(8): OPTIONAL 

 

This field specifies the action pattern code to execute for matching alarm signals.  

This is optional and if left empty, the default actions code of the Event Code will be 

used. 

 

SIGINST: LONGTEXT: OPTIONAL 

 

This is signal instruction text that will be presented to an alarm handling user for 

matching alarm signals. 

 

 

 

INSTIDRNG (1028) 

 

This item corresponds to the TX ID Ranges Jump To item in Dealer Maintenance. As with 

INSTCHG, the fields listed are in order as they appear in the client from left to right.  Range 

Full and Restart are not included.  CONTID + RLDES + TXIDFRM must be unique.   

 

CONTID: CODE(12) 

  

CONTID must reference a valid dealer. 

 

RLDES: CODE(5) 
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This must reference a valid Receiver Line Prefix.  Receiver Line Prefix information 

can be found in Supervisor Workstation under Maintenance > Setup > Receivers, in 

the ‘Rec Line Prefixes’ section of the tree. 

 

TXIDFRM: CODE(12) 

 

This is the starting transmitter ID of the transmitter range being assigned to this 

dealer (inclusive).  The length of TXIDFRM and TXIDTO should be the same (leading 

zeros do not count and will be removed) since the comparisons are alpha-numeric 

to allow for hexadecimal values.  A range of 950 – 1050 would be invalid.  This 

would need to be assigned in two ranges, 950 – 999 and 1000 – 1050. 

 

TXIDTO: CODE(12) 

 

This is the ending transmitter ID of the transmitter range (inclusive). 

 

NEXTTXID: CODE(12): OPTIONAL 

 

This is the next transmitter ID to be assigned from this transmitter range. 

 

TXIDTYPE: VALUE: OPTIONAL 

 

This is the transmitter numbering type.  0 = Unknown (this is also the default value), 

1 = Decimal, 2 = Hexadecimal, 3 = Hexadecimal excluding A. 

 

INSTRATE (1029) 

 

CONTID + RATECODE must be unique. 

 

CONTID: CODE(12) 

 

CONTID must reference a valid dealer. 

 

RATECODE: CODE(5) 

 

DESCR: STRING(35): OPTIONAL 

 

Description. 

 

TYPE: VALUE: OPTIONAL 

 

Count Type (0 = Dealer, 1= Customer) 
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INSTRATE_D (1030) 

 

CONTID: CODE(12) 

 

CONTID must reference a valid dealer. 

 

RATECODE: CODE(5) 

 

Rate Code. 

 

MINQTY: VALUE: OPTIONAL 

 

Minimum quantity required for this rate level. 

 

BASEPRICE: MONEY: OPTIONAL 

 

Base price for this rate level. 

 

ADDLPRICE: MONEY: OPTIONAL 

 

Additional price per unit above MinQty. 

 

 

INSTTX (1031) 

 

INSTTX is the Tx Types in the Dealer Maintenance form.  CONTID + TXTYPE must be 

unique. 

 

CONTID: CODE(12) 

 

CONTID must reference a valid dealer. 

 

TXTYPE: CODE(12) 

 

This must reference a valid Transmitter Type.  Transmitter Type information can be 

found in Operator Workstation under Maintenance > Transmitter Types.  

 

 

MONSRV (1052) 

 

MONSRV corresponds to the Services Jump To item in Customer Maintenance.  Only 

monitoring types with an “other” attribute can be specified and must already exist in the 
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database (entered via Supervisor Workstation).  The monitoring type number as stored in 

the database must be specified in the import data.  Unfortunately, there is not a good way 

to obtain the number other than executing a SQL query to see the information in the 

database table.  Executing the query select * from MONTYPE where ATTR = 'Z' will list the 

monitoring types that can be used when importing a service. 

The MONLEVEL (see results of above query) of the MONTYPE must correspond to the 

information provided in the import data.  The following MONLEVEL values expect the 

import data to be as listed: 

MONLEVEL 0 (customer service) requires SYSNO = -1.  Any COMMSNO or AREA provided 

will be ignored. 

MONLEVEL 2 (sub-system service) requires a valid SYSNO and no COMMSNO or AREA. 

MONLEVEL 3 (transmitter service) requires a valid SYSNO and COMMSNO.  Any AREA 

provided will be ignored. 

MONLEVEL 4 (area service) requires a valid SYSNO and AREA, and no COMMSNO. 

In other words: 

• If a customer-level service is being added, the specified MONTYPE must have a 

MONLEVEL of 0 and the SYSNO must be -1. 

• If a sub-system-level service is being added, the specified MONTYPE must have a 

MONLEVEL of 2 and the SYSNO must be a valid system of the customer and 

COMMSNO and AREA must be blank. 

• If a transmitter-level service is being added, the specified MONTYPE must have a 

MONLEVEL of 3 and the SYSNO must be a valid system of the customer and 

COMMSNO must be a valid transmitter of the customer. 

• If an area-level service is being added, the specified MONTYPE must have a 

MONLEVEL of 4 and the SYSNO must be a valid system of the customer and AREA 

must be supplied and COMMSNO must be blank. 

 

CONTID: CODE(12) 

CONTID must reference a valid customer. 

SYSNO: VALUE 

This must be -1 for a customer-level service, or a valid system number of the 

customer. 

 

COMMSNO: VALUE 

This is only provided for a transmitter-level service and would have to be a valid 

transmitter of the customer. 
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AREA: CODE(4) 

This is only provided for an area-level service and would have to be a valid area of 

the customer. 

 

MONTYPE: VALUE 

This is the number of the desired monitoring type (see above explanation) of the 

service being added.  The MONLEVEL of the monitoring type must correspond to the 

SYSNO/COMMSNO/AREA being specified. 

 

QUAL1: VALUE: OPTIONAL 

Not used at this time and will be ignored. 

 

QUAL2: STRING(12): OPTIONAL 

Not used at this time and will be ignored. 

 

CHARGE: YES/NO 

This specifies whether or not the service is billable. 

 

DATETOST: DATE: OPTIONAL 

This specifies the start date of the service 

 

DATETOTM: DATE: OPTIONAL 

This specifies the end date of the service. 

 

 

OC_SCHED (1032) 

 

OC_SCHED corresponds to the O/C Schedules Jump To item in Customer Maintenance. As 

with CALLLIST and others, this item corresponds primarily with labels and identifiers for 

schedules. The bulk of actual schedule data is found in OC_SCHED_D.  CONTID + SCHEDNO 

must be unique. 

 

CONTID: CODE(12) 

 

CONTID must reference a valid customer. 
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SCHEDNO: CODE(4) 

 

This is the code or ID of this schedule. 

 

DESCR: STRING(35) 

 

WCODE: CODE(8): OPTIONAL 

 

If supplied, this must reference a valid Window Code.  Window Codes can be found 

in the Supervisor Workstation under Maintenance > Schedule Window Codes. 

 

 

 

OC_SCHED_D (1033) 

 

OC_SCHED_D corresponds to actual schedule definitions, such as dates and times.  CONTID 

+ SCHEDNO + TYPE + WINMONTH + WINDAY + WINMIN must be unique. 

 

CONTID: CODE(12) 

 

CONTID must reference a valid customer. 

 

SCHEDNO: CODE(4) 

 

CONTID + SCHEDNO must reference a valid Open/Close schedule for this customer. 

 

TYPE: VALUE 

 

This refers to the type of Open/Close schedule and must be one of the following 

values:  0=Permanent Schedule, 1=Alternate Schedule, 2=Global Holiday, 

3=Customer Holiday, 4=Temporary Schedule.  Global Holiday information can be 

found in Supervisor Workstation under Maintenance > Global Holidays. 

 

WINMONTH: VALUE 

 

This specifies the month (1-12) for holiday type schedules.  For all schedule types, 

this value must be ‘0’. 

 

WINDAY: VALUE 

 

This specifies the day of the month for holiday type schedules and the day of the 

week for all other schedule types where 0=Monday and 6 = Sunday. 

 

WINMIN: VALUE 
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This specifies the time of the day in minutes for the required status.  0 corresponds 

to 00:00 and 1439 (the maximum allowed value) corresponds to 23:59. 

 

DATEFRM: DATE: OPTIONAL 

 

This specifies the first date that this schedule entry will be active and is valid for 

schedule types 1 and 4 only.  For schedule type 1 (Alternate), all detail lines must 

have the same DATEFRM and DATETO values.  For schedule type 4 (Temporary), 

DATETO must equal DATEFRM. 

 

STATUS: VALUE 

 

This specifies the status for the window beginning or ending at the above specified 

time and must be one of the following values:  0=Must Open, 1=Must Close, 2=May 

Open, 3=May Close, 4=May Open/Close, 5=May Open/Close Once, 6=No Activity, 

7=May Temp Open, 8=May Temp Open Once. 

 

DATETO: DATE: OPTIONAL 

 

This specifies the last date that this schedule entry will be active and is valid for 

schedule types 1 and 4 only.  For schedule type 1 (Alternate), all detail lines must 

have the same DATEFRM and DATETO values.  For schedule type 4 (Temporary), 

DATETO must equal DATEFRM. 

 

 

 

PANELTYPE (1034) 

 

PANELTYPE corresponds to the control panel types configured in Manitou.  For examples, 

extant control panel information can be found in Supervisor Workstation under 

Maintenance > Control Panels.  PANELTYPE must be unique. 

 

PANELTYPE: CODE(25) 

 

This is the Panel Type code. 

 

DESCR: STRING(35) 

 

This is the Panel Type description. 

 

DEFTXTYPE: CODE(35): OPTIONAL 
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This is the default Transmitter Type to be used when adding transmitters for a 

customer system with this Panel Type. Transmitter Type information can be found 

in Operator Workstation under Maintenance > Transmitter Types. 

 

REMTYPE: VALUE: OPTIONAL 

 

This is the default Remote Reset type, which is only available in the UK (Country 44) 

configurations. 

 

MAXAREAS: VALUE: OPTIONAL 

 

This specifies the maximum number of areas that will be allowed for a customer 

system with this Panel Type.  A value of -1 means that there is no limit. 

 

MAXZONES: VALUE: OPTIONAL 

 

This specifies the maximum number of zones that will be allowed for a customer 

system with this Panel Type.  A value of -1 means that there is no limit. 

 

MAXTX: VALUE: OPTIONAL 

 

This specifies the maximum number of transmitters that will be allowed for a 

customer system with this Panel Type.  A value of -1 means that there is no limit. 

 

MAXUSRS: VALUE: OPTIONAL 

 

This specifies the maximum number of Open/Close user ID’s that will be allowed for 

a customer system with this Panel Type.  A value of -1 means that there is no limit. 

 

HELP: LONGTEXT: OPTIONAL 

 

This is text that will be presented to the user on the customer system maintenance 

form when this Panel Type is selected. 

 

 

PERMIT (1035) 

 

PERMIT corresponds to the Permits form in Customer Maintenance.  CONTID + AUTHTYPE 

+ PERMTYPE must be unique. 

 

CONTID: CODE(12) 

 

CONTID must reference a valid customer. 
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AUTHTYPE: VALUE 

 

This is the Authority subtype and must be one of the following:  0=Police, 1=Fire, 

2=Medical. 

 

PERMTYPE: VALUE 

 

This must reference a valid Permit Type.  Permit Types can be found in Supervisor 

Workstation under Maintenance > Permit Types and are defined by country. 

 

PERMIT: CODE(15) 

 

PERMSTAT: VALUE: OPTIONAL 

 

This specifies the Permit Status and must be one of the following values: 

0=Unknown, 1=Level 1 (Authority will attempt to respond – normal), 2=Level 2 

(Authority may respond), 3=Level 3 (no response). 

 

PERMSTATDATE: DATE: OPTIONAL 

 

This specifies the date at which the above status went into effect. 

 

EXPDATE: DATE: OPTIONAL 

 

This specifies the date at which the permit will expire. 

 

 

REMINDER (1037) 

 

REMINDER corresponds to the Reminder section of a customer system. 

 

CONTID: CODE(12) 

 

CONTID must reference a valid customer. 

 

SYSNO: VALUE 

 

CONTID + SYSNO must reference a valid customer system. 

 

STCODE: CODE(8) 

 

This specifies a standard alarm code. 

 

DESCR: STRING(35): OPTIONAL 
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This specified a description for the reminder. 

 

QUAL1: CODE(4) : OPTIONAL 

 

This specifies an Area for Event Monitoring systems and should be Null for other 

system types. 

 

QUAL2: CODE(5) : OPTIONAL 

 

This specifies a Zone for Event Monitoring systems, an Asset for GPS systems, and 

should be Null for other system types. 

 

POINTID: STRING(50) : OPTIONAL 

 

This specifies the Point ID description from location. 

 

SCHEDNO: CODE(4) : OPTIONAL 

 

This specifies a general schedule number.  It must be of type 7 (Reminder Schedule). 

 

RANDOMIZE: YES/NO: OPTIONAL 

 

This specifies if reminder randomization is active, enabling the STARTMINUS, 

INTVLMINUS, INTVLPLUS, and ENDPLUS fields. 

 

STARTMINUS: VALUE: OPTIONAL 

 

This specifies the number of minutes preceding the beginning of the schedule 

window where the first reminder may occur. 

 

INTVLMINUS: VALUE: OPTIONAL 

 

This specifies the number of minutes preceding the next reminder within a schedule 

window where the reminder may occur. 

 

INTVLPLUS: VALUE: OPTIONAL 

 

This specifies the number of minutes past the next reminder within a schedule 

window where the reminder may occur. 

 

ENDPLUS: VALUE: OPTIONAL 

 

This specifies the number of minutes past the end of a schedule window where the 

last reminder may occur. 
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REMUNIT: VALUE 

 

This specifies the interval unit (0 = Minutes, 1 = Hours, 2 = Days). 

 

REMINTVL: VALUE 

 

This specifies the interval value. 

 

REMCNT: VALUE: OPTIONAL 

 

This specifies the number of occurrences (mutually exclusive of SCHEDNO) 

 

REMTYPE: VALUE: OPTIONAL 

 

This specifies the type of reminder (0 = Create Signal, 1 = Create Maintenance 

Issue). 

 

NEXTBASE: DATETIME 

 

This specifies the next reminder will occur (UTC).  Does not take randomization 

variables into account. 

 

DATETOTM: DATETIME: OPTIONAL 

 

This specifies the termination date for the service. 

 

AUTOPURGE: YES/NO: OPTIONAL 

 

This specifies whether to automatically purge reminders once they are expired. 

 

HELP: LONGTEXT: OPTIONAL 

 

This specifies help text about the reminder. 

 
 

SAREA (1038) 

An example SAREA string is represented as follows: 

// Sarea 

1038,"SIUTEST0002",1,"2","",,,"Area 2 on System 1-0123456789012345" 

 

SAREA corresponds to the Area section of a customer system.  CONTID + SYSNO + AREA 

must be unique. 

 

CONTID: CODE(12) 
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CONTID must reference a valid customer. 

 

SYSNO: VALUE 

 

CONTID + SYSNO must reference a valid customer system. 

 

AREA: CODE(4) 

 

This specifies the number or identifier of the area. 

 

SCHEDNO: CODE(4): OPTIONAL 

 

If specified, this must reference a valid Open/Close schedule for this customer, or 

else represent the “All” option by specifying four asterisks (“****”). 

 

OCTYPE: VALUE: OPTIONAL 

 

Qualifier for the Open/Close Schedule monitoring service; 0 = Monitor, 1 = Record 

 

MANVERTYPE: VALUE: OPTIONAL 

 

Qualifier for the Open/Close Manual Verify monitoring service; 0 = Both, 1 = Open, 2 

= Close 

 

DESCR: STRING(35) 

 

This is the description for the area. 

 

 

SASSET (1039) 

 

SASSET corresponds to the Asset section of a customer system.  CONTID + SYSNO + 

TRACKID must be unique. 

 

CONTID: CODE(12) 

 

CONTID must reference a valid customer. 

 

SYSNO: VALUE 

 

CONTID + SYSNO must reference a valid customer system. 

 

TRACKID: CODE(5) 



Bold Technologies | Data Record Numeric Codes 61 

 

 

This specifies the number or identifier of the Asset.   

 

DESCR: STRING(35): OPTIONAL 

 

This is the description for the Asset. 

 

REFCONTTYPE: VALUE: OPTIONAL 

 

This specifies the type of contact in the customer’s contact list that represents the 

Asset to be tracked. 

 

REFCONTID: CODE(12) : OPTIONAL 

 

This specifies the ID of the contact in the customer’s contact list that represents the 

Asset to be tracked. 

 

PERSONNAME: STRING(50) : OPTIONAL 

 

This, along with PERSONREFID, specifies the person in the customer’s contact list 

that represents the Asset to be tracked.  This field is mutually exclusive of 

REFCONTID.  REFCONTTYPE must be 100 (Person) if PERSONNAME/PERSONREFID 

is used. 

 

PERSONREFID: STRING(50) : OPTIONAL 

 

This, along with PERSONNAME, specifies the person in the customer’s contact list 

that represents the Asset to be tracked.  This field is mutually exclusive of 

REFCONTID.  REFCONTTYPE must be 100 (Person) if PERSONNAME/PERSONREFID 

is used. 

 

SCHEDNO: CODE(4) : OPTIONAL 

 

This specifies the schedule to use.  It must be of type 4 (Check-In Schedule). 

 

INTERVAL: VALUE 

 

This specifies the interval, in minutes, for check in. 

 

STATUS: VALUE 

 

This specifies the last tracking status (0 = Stopped, 1 = Late to Start, 2 = Late to 

Check In, 3 = Current). 

 

LASTLOC: STRING(80) : OPTIONAL 
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This specifies the last location received as GPS coordinates. 

 

NXTCHKST: DATETIME: OPTIONAL 

 

This specifies the next check window start. 

 

NXTCHKLATE: DATETIME: OPTIONAL 

 

This specifies the next check window late. 

 

CURCYCLEND: DATETIME: OPTIONAL 

 

This specifies the current cycle end. 

 

NXTCYCLST: DATETIME: OPTIONAL 

 

This specifies the next cycle window start. 

 

NXTCYCLLATE: DATETIME: OPTIONAL 

 

This specifies the next cycle window late. 

 

NXTCYCLEND: DATETIME: OPTIONAL 

 

This specifies the next cycle end. 

 

ADHOC: YES/NO: OPTIONAL 

 

This specifies if ad hoc check-ins are allowed. 

 

 

 

STX (1040) 

An example STX string is represented as follows: 

// Stx 

1040,"SIUTEST0002",1,"Transmitter 1 for SIU test 

customer","99","123456789",1,"DFLT",2,15,"9995551234","9995554321",,,,,,,0,1,0,0,0,0,0,"

","","","These are notes about this transmitter.",0 

 

STX corresponds to the Transmitters section of a customer system.  CONTID + COMMSNO 

must be unique. 

 

CONTID: CODE(12) 
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CONTID must reference a valid customer. 

 

COMMSNO: VALUE 

 

This is the transmitter number. 

 

DESCR: STRING(35): OPTIONAL 

 

This is the description of the transmitter. 

 

RLDES: CODE(5) 

 

This must reference a valid Receiver Line Prefix.  Receiver Line Prefix information 

can be found in Supervisor Workstation under Maintenance > Setup > Receivers, in 

the ‘Rec Line Prefixes’ section of the tree. 

 

TXID: CODE(128) 

 

This specifies the ID of the transmitter.  RLDES + TXID must be unique throughout 

all of Manitou. 

 

SYSNO: VALUE 

 

This must reference a valid system for the specified customer. 

 

TXTYPE: CODE(12) 

  

This must reference a valid Transmitter Type.  Transmitter Type information can be 

found in Operator Workstation under Maintenance > Transmitter Types. 

 

TESTUNIT: VALUE 

 

This specifies the transmitter test unit for this transmitter and must be one of the 

following values:  0=minutes, 1=hours, 2=days. 

 

TESTINTVL: VALUE: OPTIONAL 

 

This specifies the transmitter test interval for this transmitter.  A value of 0 means 

that this transmitter will not be sending a ‘test’ signal. 

 

REF1: CODE(20) : OPTIONAL 

 

This specifies the Caller-Id (phone number) of this transmitter. 

 

REF2: CODE(20) : OPTIONAL 
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This specifies the secondary Caller-Id (phone number) of this transmitter. 

 

PATHENBLDATE: DATE : OPTIONAL 

 

This is the communications path enabled date. 

 

CONNECTDATE: DATE : OPTIONAL 

 

This is the date that the transmitter was connected. 

 

TERMDATE: DATE : OPTIONAL 

 

This is the date that the transmitter was disconnected. 

 

NETADDR: CODE(50) : OPTIONAL 

 

This is the transmitter’s network address. 

 

ATTR: CODE(10) : OPTIONAL 

 

This specifies various attributes of the transmitter and may contain any 

combination of the following characters:  A=Audio Capable, V=Video Capable, 

M=Mobile Device, L=Late-to-test only when closed, N=Monitored transmission path, 

X=VertX Access Control device (this applies only to Access Control systems). 

 

PROTTYPE: CODE(8) : OPTIONAL: Must reference a valid TXPROTFMT 

 

If supplied, this must reference a valid Transmitter Protocol Type. Transmitter 

Protocol Type information can be found in Supervisor Workstation under 

Maintenance > Setup > Transmitter Protocol Types. 

 

RESTODUE: YES/NO: OPTIONAL 

 

This specifies whether unrestored alarms from this transmitter will raise a ‘Restore 

Overdue’ alarm if not restored in the allotted time. 

 

ANYTEST: YES/NO: OPTIONAL 

 

This specifies whether any signal from this transmitter will satisfy the ‘test’ signal 

requirements. 

 

EXTENDED: YES/NO: OPTIONAL 

 

This is an information only field that indicates whether this transmitter sends 

signals in extended format. 
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INSTDEF: YES/NO: OPTIONAL 

 

This specifies whether Dealer Programming will be examined or ignored.  A ‘Yes’ 

value will cause signals from this transmitter to ignore any dealer specific event 

programming. 

 

RAWPRG: YES/NO: OPTIONAL 

 

This specifies whether ‘raw’ programming will be allowed for this transmitter from 

Transmitter Programming maintenance. 

 

REGACT: YES/NO: OPTIONAL 

 

This specifies whether regular (“frequent”) signal activity is expected from this 

transmitter.  This indicator can be used in reporting. 

 

BCKUP: YES/NO: OPTIONAL 

 

This specifies whether this is a backup transmitter. 

 

AREAOFFS: CODE(4) : OPTIONAL 

 

This specifies the offset to be applied to the Area portion of all signals from this 

transmitter. 

 

ZONEOFFS: CODE(5) : OPTIONAL 

 

This specifies the offset to be applied to the Zone portion of all signals from this 

transmitter. 

 

SENSOROFFS: CODE(12) : OPTIONAL 

 

This specifies the offset to be applied to the Sensor portion of all signals from this 

transmitter. 

 

NOTES: LONGTEXT: OPTIONAL 

 

This specifies the notes or comments associated with this transmitter and are 

available for viewing on an alarm screen. 

 
MONTHREAT: YES/NO: OPTIONAL 

 

Monitors threat level changes (one YES per customer) 
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STXLINK (1041) 

 

STXLINK corresponds to the Transmitter Linking item in the Systems form. 

 

Notes: Key is not unique.  SUBACC must be NULL if the CONTID refers to a Customer that is 

not a MAIN account.  If SUBACC is NULL, then SYSNO, OAREA, and OZONE refer to the 

Customer referred to be CONTID.  The SYSNO can only refer to an even monitoring system. 

 

CONTID: CODE(12) 

 

CONTID must reference a valid customer. 

 

COMMSNO: VALUE 

 

Must reference a valid STX.  This must reference a valid transmitter number for this 

customer. 

 

AREA: CODE(4) 

 

This is the Area of signals to match for linking.  A value of “*” is allowed which 

indicates any area. 

 

ZONE: CODE(5) 

 

This is the Zone of signals to match for linking.  A value of “*” is allowed which 

indicates any zone. 

 

EVCAT: CODE(8): OPTIONAL 

 

If supplied this must reference a valid Event Category. 

 

SUBACC: CODE(12): OPTIONAL 

 

Must reference a valid CUSTOMER.  If this customer is a main customer (has sub-

accounts), then the sub-account’s Contact ID can be specified here to redirect 

matching signal to this sub-account.  If supplied, this must reference a sub-account 

of this customer. 

  

SYSNO: VALUE 

 

This must reference a valid system of this customer or sub-account if SUBACC 

supplied above. 

 

OAREA: CODE(4) 
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This is the Area value that will be applied to matching signals.  A value of “=” is 

allowed which indicates that the signal’s area value should be left unchanged. 

 

OZONE: CODE(5) 

 

This is the Zone value that will be applied to matching signals.  A value of “=” is 

allowed which indicates that the signal’s zone value should be left unchanged. 

 

 

STXPRG (1042) 

 

STXPRG Transmitter Programming section of a customer system, found in the Systems 

form of Customer Maintenance. 

 

CONTID: CODE(12) 

 

CONTID must reference a valid customer. 

 

SYSNO: VALUE 

 

This must reference a valid system for the specified customer. 

 

COMMSNO: CODE(4) 

 

This must reference a valid transmitter number for this customer.  A value of “*” is 

allowed to indicate any transmitter of this system. 

 

DES: CODE(9) 

 

This specifies the designation or original event code of the signal to be programmed.  

If ‘raw programming’ is enabled for this transmitter, ‘#’ plus the pre-mapped event 

designation of the signal is allowed. 

 

DESCR: STRING(20): OPTIONAL 

 

This specifies the Description that will be shown for matching signals.  If this field is 

left blank, the event description from the Event Code specified below will be used. 

 

AREA: CODE(4): OPTIONAL 

 

This specifies the Area value to be used to match signals.  A value of “*” is allowed to 

indicate any area. 

 

ZONE: CODE(5): OPTIONAL 
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This specifies the Zone value to be used to match signals.  The ‘*’ wildcard indicator 

is allowed as the last character of the zone value.  For example, “*” and “3*” are 

allowed. 

 

For GPS systems this specifies the TRACKID for an Asset. 

 

SENSOR: CODE(12): OPTIONAL 

 

This specifies the Sensor value to be used to match signals.  A value of “*” is allowed 

to indicate any sensor. 

 

OAREA: CODE(4): OPTIONAL 

 

This specifies the Area value that the matching signal will be assigned.  A value of “=” 

is allowed which indicates that the signal’s area value should be left unchanged. 

 

OZONE: CODE(5): OPTIONAL 

 

This specifies the Zone value that the matching signal will be assigned.  The ‘=’ 

replacement indicator is allowed which be replaced with any wild carded characters 

of the ZONE field.  For example, if ZONE was “3*” OZONE was “57=”, and the signal’s 

zone was “31”, the signal’s zone will be assigned a value of “571”. 

 

OSENSOR: CODE(12): OPTIONAL 

 

This specifies the Sensor value that the matching signal will be assigned.  A value of 

“=” is allowed which indicates that the signal’s sensor value should be left 

unchanged. 

 

STCODE: CODE(8) 

 

This specifies the Event Code that matching signals will be assigned.  Event Codes 

can be found in Supervisor Workstation under Maintenance > Events > Event Codes. 

 

POINTID: STRING(50): OPTIONAL 

 

This specifies the Point ID description to be assigned to matching signals. 

 

PROCESS: STRING(128): OPTIONAL 

 

This specifies the Processing Commands to be applied to matching signals.  Please 

note that this must match the proper command syntax. 

 

HELP: LONGTEXT: OPTIONAL 
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This specifies the ‘help’ instructions to be assigned to matching signals.  This help 

text is available on the alarm screen. 

 

 

 

SZONES (1043) 

 

SZONES are located in the Zones section of a customer system. The fields listed correspond 

to the layout of the Zones form as read from left to right.  CONTID + SYSNO + AREA + ZONE 

must be unique. 

 

CONTID: CODE(12) 

 

CONTID must reference a valid customer. 

 

SYSNO: VALUE 

 

CONTID + SYSNO must reference a valid customer system. 

 

AREA: CODE(4) 

 

This specifies the number or identifier of the area.  CONTID + SYSNO + AREA must 

reference a valid customer area.  A value of “*” is allowed to indicate any area of this 

system. 

 

ZONE: CODE(5) 

 

This specifies the number or identifier of the zone.   

 

DESCR: STRING(3550 

 

This is the description of the zone. 

 

EVCAT: CODE(8): OPTIONAL 

 

If supplied, this must reference a valid Event Category.  The field should only be 

used if the option to redirect by event codes for non-intelligent panels is set.  This 

option can be found in Supervisor Workstation under Tools > Options > Signal 

Processing > Redirect event codes for non-intelligent panels.  Event Category 

information can be found in Supervisor Workstation under Maintenance > Events > 

Event Categories. 

 

 

TXEVENTPRG (1044) 
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TXEVENTPRG corresponds to the bottom portion of the Event Programming tab for a 

transmitter, and is largely identical to the Event Action Programming on customer systems 

(the EVENTPRG record), only applied at the Transmitter level. 

 

Note: Key is not unique. 

 

TXTYPE: CODE(12) 

 

This must reference a valid Transmitter Type.  Transmitter Type information can be 

found in Operator Workstation under Maintenance > Transmitter Types. 

 

STCODE: CODE(8) 

 

This specifies the Event Code that matching signals will be assigned.  Event Codes 

can be found in Supervisor Workstation under Maintenance > Events > Event Codes. 

 

AREA: CODE(4): OPTIONAL 

 

This field qualifies when the supplied Actions code will be applied to alarm signals.  

It must match the area of the signal or can be “*” which will match any area. 

 

ZONE: CODE(5): OPTIONAL 

 

This field qualifies when the supplied Actions code will be applied to alarm signals.  

It must match the zone of the signal or can be “*” which will match any zone or any 

partial match (e.g., “2*” which would match any zone that starts with a ‘2’). 

 

For GPS systems, this specifies the TRACKID for an Asset. 

 

ALARM: VALUE: OPTIONAL 

 

This field determines the behavior of the signal (whether it will be an alarm or not) 

when the signal matches this entry.  The possible values are:  0=No (will not be an 

alarm – value assigned if not supplied), 1=Yes (will be an alarm), 2=Default (use 

alarm setting of the Event Code). 

 

ACTIONMODE: VALUE 

 

ACTIONS: CODE(8): OPTIONAL 

 

This field specifies the action pattern code to execute for matching alarm signals.  

This is optional and if left empty, the default actions code of the Event Code will be 

used. 

 

SIGINST: LONGTEXT: OPTIONAL 
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This is signal instruction text that will be presented to an alarm handling user for 

matching alarm signals. 

 

THREAT: VALUE: OPTIONAL 

 

Threat level (-1=any) 

 

 

TXTYPE (1045) 

 

TXTYPE corresponds with the transmitter types set up in Operator Workstation under 

Maintenance > Transmitter Types.  TXTYPE must be unique. 

 

TXTYPE: CODE(12) 

 

This specifies the transmitter type code and must be unique. 

 

DESCR: STRING(35): OPTIONAL 

 

This is the description for the transmitter type. 

 

SYSTYPE: VALUE 

 

This specifies the type of transmitter and must be one of the following values:  

0=Event Monitoring, 1=Access Control, 2=GPS. 

 

PROTOCOL: VALUE: OPTIONAL 

 

If supplied, this must reference a valid Reverse Command Protocol.  Reverse 

Command Protocol information can be found in Supervisor Workstation under 

Maintenance > Setup > Subtypes, in the Reverse Command Types section. 

 

PROTTYPE: CODE(8): OPTIONAL 

 

If supplied, this must reference a valid Protocol Type.  Protocol information can be 

found in Supervisor Workstation under Maintenance > Setup > Transmitter Protocol 

Types. 

 

ATTR: CODE(8): OPTIONAL 

 

This specifies various default attributes that will be applied to a transmitter when 

this transmitter type is selected and may contain any combination of the following 
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characters:  A=Audio Capable, V=Video Capable, L=Late-to-test only when closed, 

N=Monitored transmission path. 

 

AUDIOTYPE: CODE(8): OPTIONAL: Must reference a valid AUDIO 

 

If supplied, this must reference a valid Audio Type and ATTR above must contain an 

‘A’.  Audio Type information can be found in Supervisor Workstation under 

Maintenance > Setup > Audio Types. 

 

VIDEOTYPE: CODE(8): OPTIONAL: Must reference a valid VIDEO 

 

If supplied, this must reference a valid Video Type and ATTR above must contain a 

‘V’.  Video Type information can be seen from the Operator Workstation in the drop-

down list of Video Types on the Transmitter Types maintenance form. 

 

RAWPRG: YES/NO 

 

This specifies whether ‘raw’ programming will be allowed for this transmitter type 

from Transmitter Type > Programming tab maintenance. 

 

 

 

TXTYPEPRG (1046) 

 

TXTYPEPRG corresponds to the top portion of the Event Programming tab for a 

transmitter.  As with TXEVENTPRG, this is largely identical to the Transmitter 

Programming in customer accounts (the STXPRG record), only applied at the transmitter 

level. 

 

TXTYPE: CODE(12) 

 

This must reference a valid Transmitter Type.  Transmitter Type information can be 

found in Operator Workstation under Maintenance > Transmitter Types. 

 

DES: CODE(9) 

 

This specifies the designation or original event code of the signal to be programmed.  

If ‘raw programming’ is enabled for this transmitter, ‘#’ plus the pre-mapped event 

designation of the signal is allowed. 

 

DESCR: STRING(20): OPTIONAL 

 

This specifies the Description that will be shown for matching signals.  If this field is 

left blank, the event description from the Event Code specified below will be used. 
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AREA: CODE(4): OPTIONAL 

 

This specifies the Area value to be used to match signals.  A value of “*” is allowed to 

indicate any area. 

 

ZONE: CODE(5): OPTIONAL 

 

This specifies the Zone value to be used to match signals.  The ‘*’ wildcard indicator 

is allowed as the last character of the zone value.  For example, “*” and “3*” are 

allowed. 

 

For GPS systems, this specifies the TRACKID for an Asset. 

 

SENSOR: CODE(12): OPTIONAL 

 

This specifies the Sensor value to be used to match signals.  A value of “*” is allowed 

to indicate any sensor. 

 

OAREA: CODE(4): OPTIONAL 

 

This specifies the Area value that the matching signal will be assigned.  A value of “=” 

is allowed which indicates that the signal’s area value should be left unchanged. 

 

OZONE: CODE(5): OPTIONAL 

 

This specifies the Zone value that the matching signal will be assigned.  The ‘=’ 

replacement indicator is allowed which be replaced with any wild carded characters 

of the ZONE field.  For example, if ZONE was “3*” OZONE was “57=”, and the signal’s 

zone was “31”, the signal’s zone will be assigned a value of “571”. 

 

OSENSOR: CODE(12): OPTIONAL 

 

This specifies the Sensor value that the matching signal will be assigned.  A value of 

“=” is allowed which indicates that the signal’s sensor value should be left 

unchanged. 

 

STCODE: CODE(8) 

 

Must reference a valid EVENTDEF.  This specifies the Event Code that matching 

signals will be assigned.  Event Codes can be found in Supervisor Workstation under 

Maintenance > Events > Event Codes. 

 

POINTID: CODE(50): OPTIONAL 

 

This specifies the Point ID description to be assigned to matching signals. 
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PROCESS: STRING(128): OPTIONAL 

 

This specifies the Processing Commands to be applied to matching signals.  Please 

note that this must match the proper command syntax. 

 

HELP: LONGTEXT: OPTIONAL 

 

This specifies the ‘help’ instructions to be assigned to matching signals.  This help 

text is available on the alarm screen. 

 

THREAT (1047) 

 

THREAT corresponds the threat form in Supervisor Workstation. THREATID must be 

unique 

 

THREATID: VALUE 

 

DESCR: STRING(35): OPTIONAL 

 

COLOR: VALUE: OPTIONAL 

 

ICONINDEX: VALUE: OPTIONAL 

 

 

CLOG (1011) 

 

Notes: Key is not unique.  Each EVTYPE dictates which fields will be used and the 

semantics of each.  (See the guide below.)  Remember that, when using import files, CLOG 

records are inserted in the order you provide them in the file; therefore, be sure to begin 

with the oldest records first. 

 

Standard Import will create the appropriate CLOG table in the Manitou database for you if 

one does not already exist for the LOGDATE specified in the data row. 

 

CONTID: CODE(12) 

 

CONTID must reference a valid customer. 

 

ORDERSEQ: VALUE: OPTIONAL: CID ONLY 

 

This optional value is used to order the CLOG rows when they are coming from the 

CID.  Because CLOG rows must be in a specific order (i.e. a summary row followed 
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by all its details), ORDERSEQ is provided to allow explicit ordering.  This value is not 

valid when using import files. 

 

LOGDATE: DATETIME 

 

This is the date/time of the event or action in UTC time. 

 

EVTYPE: VALUE 

 

This refers to the event type and must be of of the following values: 

0,1,2,3,4,6,9,14,15,16,26,27,28,29,32,36,37,40,41.  See examples below. 

 

DETAIL: YES/NO: OPTIONAL 

 

This indicates whether this line is a detail line or not.  Detail lines will be added to 

the previous Summary line.  The first line of activity cannot be a detail line.  The 

default setting is ‘No’. 

 

STRING1: STRING(50) : OPTIONAL 

 

STRING2: STRING(80) : OPTIONAL 

 

STRING3: CODE(8) : OPTIONAL 

 

STRING4: CODE(8) : OPTIONAL 

 

STRING5: STRING(20) : OPTIONAL 

 

STRING6: CODE(8) : OPTIONAL 

 

STRING7: CODE(12) : OPTIONAL 

 

SMALLINT1: VALUE : OPTIONAL 

 

STRING8: CODE(4) : OPTIONAL 

 

STRING9: CODE(5) : OPTIONAL 

 

STRING10: CODE(5) : OPTIONAL 

 

SMALLINT2: VALUE: OPTIONAL 

 

SMALLINT3: VALUE: OPTIONAL 

 

STRING11: CODE(8) : OPTIONAL 
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STRING12: CODE(8) : OPTIONAL 

 

DATETIME1: DATETIME: OPTIONAL 

 

DATETIME2: DATETIME: OPTIONAL 

 

STRING13: CODE(4) : OPTIONAL 

 

SMALLINT4: VALUE: OPTIONAL 

 

SMALLINT5: VALUE: OPTIONAL 

 

INTEGER1: VALUE: OPTIONAL 

 

INTEGER2: VALUE: OPTIONAL 

 

STRING14: STRING(512) : OPTIONAL 

 

 

The following guide shows all possible fields for each EVTYPE: 

 

EVTYPE = 0: Signal and 

EVTYPE = 9: Ignored Signal 

 

STRING1: “POINTID”: OPTIONAL 

STRING2: “EVSTRING”: OPTIONAL 

STRING3: “STCODE” 

STRING4: “EVCAT” 

STRING5: “EVENTNAME” 

STRING6: “RLDES”: OPTIONAL 

STRING7: “TXID”: OPTIONAL 

SMALLINT1: “SYSNO”: OPTIONAL 

STRING8: “AREA”: OPTIONAL 

STRING9: “ZONE”: OPTIONAL 

STRING10: “SECTOR”: OPTIONAL 

 

 

EVTYPE = 1: Alarm 

 

STRING1: “POINTID”: OPTIONAL 

STRING2: “EVSTRING”: OPTIONAL 

STRING3: “STCODE” 

STRING4: “EVCAT” 

STRING5: “EVENTNAME” 

STRING6: “RLDES”: OPTIONAL 

STRING7: “TXID”: OPTIONAL 
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SMALLINT1: “SYSNO”: OPTIONAL 

STRING8: “AREA”: OPTIONAL 

STRING9: “ZONE”: OPTIONAL 

STRING10: “SECTOR”: OPTIONAL 

SMALLINT2: “TYPE”: (0=False Alarm, 1=Genuine Alarm) 

SMALLINT3: “CLOSESTATUS”: (0=Normal, 1=Customer Cancel, 2=Operator Force 

Close, 4=Bulk Force Close, 8=Storm Mode) 

STRING11: “CONTACTED”: OPTIONAL: C=Customer site, K=Keyholder, P=Police, 

F=Fire, M=Medical, A=Agency, D=Dealer, B=Branch 

STRING 12: “FACHRS”: OPTIONAL: Alarm Resolution code 

DATETIME1: “GSECTIME”: Date/Time alarm was closed (UTC) 

 

 

EVTYPE = 2: Handled 

 

SMALLINT1: “PRIORITY” 

INTEGER1: “RESPONSESECS” 

 

 

EVTYPE = 3: Action 

 

SMALLINT1: “ACTIONTYPE” 

ACTIONTYPE = 1: Contact 

STRING2: “FULLNAME” 

STRING7: “CONTID”: OPTIONAL 

SMALLINT2: “CONTTYPE” 

SMALLINT3: “RESULTCODE”: (-1=Dialed, 0=Unknown, 1=Contacted, 2=Busy, 3=Not 

In, 4=Error, 5=Left Message, 6=No Answer, 7=Abort Contact Attempt, 8=Wont’ 

Respond) 

ACTIONTYPE = 7: Suspend 

SMALLINT2: “TIME” 

INTEGER1: “UNITS”: (1=Seconds, 2=Minutes, 3=Hours) 

ACTIONTYPE = 11: Report 

STRING1: “CONTPOINT” 

STRING2: “FULLNAME” 

SMALLINT2: “CPTYPE”: OPTIONAL 

ACTIONTYPE = 12: Close 

STRING2: “COMMENT”: OPTIONAL 

STRING5: “FACHRS”: OPTIONAL 

SMALLINT2: “CLOSETYPE”: (0=Normal, 1=Customer Cancel, 2=Operator Force 

Close, 4=Bulk Force Close, 8=Storm Mode) 

ACTIONTYPE = 13: Cancel 

(No additional fields necessary.) 

ACTIONTYPE = 18: Defer 

(No additional fields necessary.) 

ACTIONTYPE = 19: Ignore 
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STRING2: “COMMAND”: OPTIONAL 

 

 

EVTYPE = 4: Response Time 

 

SMALLINT1: “RESPONSECAT”: (-1=No Category, 0=Fast Life, 1=Medium Life, 

2=Slow Life, 3=Fast Other, 4=Medium Other, 5=Slow Other) 

SMALLINT2: “PRIORITY” 

INTEGER1: “VIEWED” 

INTEGER2:  “VIEWEDTOACTION” 

 

 

EVTYPE = 6: Alarm Confirmation 

 

(No additional fields necessary.) 

 

 

EVTYPE = 14: Temporary On Test 

 

STRING1: “COMMENT”: OPTIONAL 

STRING3: “STCODE”: OPTIONAL 

STRING4: “EVCAT”: OPTIONAL 

STRING7: “TICKETNO”: OPTIONAL 

SMALLINT1: “SYSNO”: OPTIONAL 

STRING8: “AREA”: OPTIONAL 

STRING9: “ZONE”: OPTIONAL 

SMALLINT2: “TYPE” 

DATETIME1: “GSRVSTART”: Date/time On Test period started (UTC) 

DATETIME2: “GSRVEND”: Date/time  of On Test period expiration (UTC) 

STRING13: “COMMSNO”: OPTIONAL 

INTEGER1: “OUTOFSERVICEID”: OPTIONAL 

STRING14: “LIST”: OPTIONAL 

 

 

EVTYPE = 15: Permanent On Test 

 

STRING1: “COMMENT”: OPTIONAL 

STRING3: “STCODE”: OPTIONAL 

STRING4: “EVCAT”: OPTIONAL 

STRING7: “TICKETNO”: OPTIONAL 

SMALLINT1: “SYSNO”: OPTIONAL 

STRING8: “AREA”: OPTIONAL 

STRING9: “ZONE”: OPTIONAL 

SMALLINT2: “TYPE” 

DATETIME1: “GSRVSTART”: Date/time On Test period started (UTC) 

STRING13: “COMMSNO”: OPTIONAL 
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EVTYPE = 16: Service Full (On Test cancelled) 

 

(No additional fields necessary.) 

 

 

EVTYPE = 26: Contact Password Verified 

 

STRING1: “PASSWORD” 

STRING2: “FULLNAME” 

SMALLINT1: “VERIFIED”: (0=False, 1=True) 

 

 

EVTYPE = 27: Police Name/ID and Ref/Incident Number 

 

STRING2: “COMMENT”: OPTIONAL 

 

 

EVTYPE = 28: Fire Name/ID and Ref/Incident Number 

 

STRING2: “COMMENT”: OPTIONAL 

 

 

EVTYPE = 29: Comment 

 

STRING2: “COMMENT” 

 

 

EVTYPE = 32: Resolution 

 

STRING3: “FACHARS” 

SMALLINT1: “ALMCOND”: (0=False Alarm, 1=Genuine Alarm) 

 

 

EVTYPE = 36: Called-In (Contact Called Back)  

 

STRING2: “FULLNAME” 

SMALLINT1: “CONTTYPE” 

SMALLINT2: “NOTIFYTYPE”: (0=Notify, 1=On-location, 2=Cleared) 

 

 

EVTYPE = 37: Medical Name/ID Number and Ref/Incident Number 

 

STRING2: “COMMENT”: OPTIONAL 
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EVTYPE = 40: Pre-Cancel 

 

STRING1: “FULLNAME” 

STRING2: “COMMENT”: OPTIONAL 

STRING3: “ORIGIN” 

STRING4: “FACHRS”: OPTIONAL 

STRING5: “CALLBACKNO”: OPTIONAL 

SMALLINT1: “CONTTYPE” 

SMALLINT2: “ISVALID”: (0=False, 1=True) 

 

 

EVTYPE = 41: Agency Ref/Name 

 

STRING2: “REFNAME” 

STRING7: “REFID” 

SMALLINT1: “CONTMETHOD”: (0=Unknown, 1=Radio, 2=Phone) 

SMALLINT2: “KEYUSED”: (0=False, 1=True) 

DATETIME1: “ARRIVALTIME” (UTC) 

INTEGER1: “RESPMIN” 

 

EVTYPE = 45: Workflow Text 

 

STRING2: “WORKFLOW_TEXT”: OPTIONAL 

 

 

 

 

RUNNING STANDARD IMPORT UTILITY 

 

Once you have configured the data files properly, you can run Standard Import Utility. 

 

First, you must create a session. A session is a set of data files to import, a variety of 

processing options, rollback information, and error logs that are saved and maintained 

even when the Import Utility is closed. To create a new session, click on the File menu and 

select New Session. Then, create a new session file and save it to the destination of your 

choice. 

 

The Current Session area of the import form displays the destination of the imported files. 

The Processing Mode displays the mode in which you are running the application. In the 

example below, the import is running in Test Mode: 
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Note: Running the Standard Import Utility in Test Mode confirms that syntax and references 

are intact. This helps you to avoid unnecessary errors during the actual import process. 

 

When you are ready to begin the session, click Start. The progress of the import displays in 

the progress bar. When the import finishes, the Results window displays as shown in the 

following screenshot: 
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The Results window notifies you of the errors, if any, that were discovered during the 
import process. 

 

Note: During processing, the progress automatically scrolls to show the last line. Selecting 
a single line in the progress list stops the list from scrolling. Additionally, when you click a 
single line, the list temporarily stops updating. Updating resumes when you page down 
on the list. 
 

Process Error Files Only 
 

Selecting the Process Error File Only checkbox creates a repository for data records that 

could not be successfully processed. When selected, all data files display grayed-out, 

except the error files. This allows you to process the error files more easily. After an 
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initial import, you can fix any errors, and then reimport the error file until all errors are 

fixed. 
 

Points to Consider 

• If the import files have changed since the initial import, the following warning message 

displays: 

 

 

This ensures that the latest import files have been imported or that the import files have 
accidentally changed. 

 

• The limit of the number of lines the system can display in the user interface is 5,000. 

When this limit is reached, the oldest messages get thrown away as new messages 

are displayed. Additionally, the bottom of the window displays the number of lines 

out of the maximum that are currently displayed. This indicates that old messages 

are being thrown away. If the line reads 5000/5000, the message list has reached its 

capacity. 

 

• Log files are split when they reach 100,000 lines. After that, a new log file is created. 

The file name displays as "SIMySession_000_Log.txt", where "000" is incremented 

for each log file that is created. 

 

Edit Menu 
The Edit menu contains the following five editing commands: 

 

• Copy Log Data to Clipboard 

• Find Next Error or Warning in Log Data 

• Find Previous Error or Warning in Log Data 

• Find Next Error in Log Data 

• Find Previous Error in Log Data 
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Copy Log Data to Clipboard 

 

Selecting the "Copy Log Data to Clipboard" command copies all of the log data to a 

clipboard, where you can paste it into another document for logging purposes. This 

command can also be executed by clicking on the Copy Log Data button. 

 

 

Find Next or Previous Warning or Error 
 

Selecting any of these options allows the user to find the next or previous warning or 

error or in the log data. This is a useful and efficient tool that eliminates the need for 

you to manually scroll through the log data to find warnings and errors. 

 

 

Tools Menu 

 

The Tools menu contains functions for creating a Common Import Database, including 

creating the tables, populating the tables, and removing tables from the database. When 

you select the Common Import Database function, the following window displays: 
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The first step in creating a database is to configure the database information. Click 

Configure Database Info to display the Advanced Options menu as shown in the following 

screenshot: 
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Enter the SQL server location, the location of the Common Import Database, and the 

associated username and password. Click Test Connection to confirm the login and password 

to the SQL database is correct. Once the database is configured, click OK to return to the 

Common Import Database Tools screen. 

 

Click Create to create an empty table with keys. You can then manually populate the tables with 

raw import data. 

 

Use the Drop Tables tab to remove any previously created tables for the current session.  
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Clicking Drop causes the following window to display: 

 

Click Yes only if you want to destroy all data in the Common Import Database. 
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The "Populate Tables" tab creates tables and inputs data in the empty tables. This is helpful 

for testing a common database for errors. 

 

 

 

Once you have created the database and populated the tables with the raw data you want, create 

an import file from the database. When completed, run the import file in Test Mode. This will 

highlight errors that occurred during the file creation process. When the system discovers errors, 

the import session will stop. You can now suspend the session, and fix the errors. Because the 

data source is in the database, you should make any necessary corrections directly in the 

database tables. 

 

  

Options Menu 

 

The Options menu allows you to select various modes for the import utility and to generate 
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class/group codes and log files. Once you select them, the options are saved to the session. 

Primary Import Source 

 

Choose whether to import from the Common Import Database or from import files as 

your source of data. 

 

Test Mode/Full Import 
 

Running the import in Test Mode checks the syntax and ensures that references are 

intact. This helps prevent unnecessary errors during import. To run the import in Test 

Mode, select the Test Mode option from the Options menu. 

 

Running the import in Full Import mode checks for unnecessary errors, but causes the 

import of the current entity to fail. We recommended running the Full Import only 

after you have first successfully run it in Test Mode. 

 

Rollback Mode 

 

Rollback Mode returns any data that was actually imported to its original state. It is 

useful when errors occur during import, and you want to undo them.  

 

In order to run a session in Rollback Mode, you must first enter the location of the 

Manitou database in the Options menu, under Advanced Options. 

 

Auto Generate Customer IDs 
 

The Auto Generate Customer IDs option allows the Import Utility to automatically 

produce Customer IDs based on the database serial number found in the Manitou 

Operator Workstation. 

 

 

 

For example, if the last serial number ends at 1103775 and the option to generate 

Customer IDs is selected, the Utility begins generating Customer IDs beginning at 

1103776. The new Customer IDs will be identical to database serial numbers, so if a 
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differing Customer ID numbering scheme is already in place for existing Customers, it 

is best not to use this option.  

 

Auto Generate Class and Group Codes 

 

The Auto Generate Class Codes and Auto Generate Group Codes options work 

independently from each other, but in an identical manner. If the import finds a Class 

or Group Code in the CUSTOPTIONS record but cannot find it in the database, it 

automatically generates one so that the reference check does not fail. There is no way 

to import a Class or Group Code independent from this function. The Auto Generate 

Class Codes and Auto Generate Group Codes options are preselected by default. 

 

The Class Code and Group Code fields are paired with an optional description that it 

uses to locate and/or automatically generate a new code. 

 

If a code is provided, Standard Import attempts to locate it in the database. If the code 

can be found, it uses it. However, if the code cannot be found, it moves on to the 

description to try to find it. The description must exactly match the database’s 

description for the code in order for Standard Import to locate it. 

 

If the description can be found, Standard Import uses the code associated with it. If the 

description cannot be found, then the system attempts to auto-generate the code. This 

is done by using the given code and inserting it into the database. Then, a description 

of the code is added.  

 

Display Messages in Progress List 

 

The Display Messages in Progress List option allows you the option of stopping the 

display of messages in the Standard Import Utility. The option displays as preselected. 

Deselect it if you want to stop displaying messages. 
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If you deselect the Display Messages in Progress List option and leave the Generate 

Log File option selected, messages still display in the log file, just not in the user 

interface. A warning will display if both the Display Messages in Progress List and 

Generate Log File options are deselected. 

 

Verbose Messages 

 

The Verbose Messages option displays as preselected. If you want to limit the amount 

of information displayed in the messages you receive, deselect the Verbose Messages 

option. 

 

Generate Log File 
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As discussed in relation to the Display Messages in Progress List option, the Generate 

Log file option displays as preselected and allows messages to display in the log file 

even when they do not display as part of the user interface. A warning will display if 

both the Display Messages in Progress List and Generate Log File options are 

deselected. 

 

Debug Mode/Time Mode 

 

Do not select either of these options unless directed to do so by Bold Technical 

Support. 

 

Advanced Options 

 

Advanced Options is the last menu choice under the Options menu. The Advanced 

Options window includes the following four tabs: Messages, Logging, Rollback, and 

Common Import Database. 

 

Messages 
 

The Messages tab allows you to define which Standard Import messages display 

to you. Messages are divided into three different categories: Informational, 

Warning, and Error. You can expand the tree to display the specific messages 

available for each message category and subcategory as shown in the following 

screenshot: 
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You can click on a specific message to display information about it. Depending on the 

type of message, this information displays either as a description or as an example. A 

description displays background information relevant to the particular message (for 

e.g., as in the “Session Information” message above – during which part of the import 

process the message is likely to display to the user). An example shows how the 

message is likely to display to the user (for e.g., as in the “Processing directive is 

deprecated” message shown below).  
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A check next to a message indicates that it will display whenever Standard Import 

encounters the importing issue for which the message was created. You can check 

or uncheck an entire message category, or an individual message.  All message 

categories and individual messages display as preselected by default. When a 

message category is selected or deselected, all individual messages in that 

category will also have the same selection status.  

 

You have the following three options for deselected messages: Exclude Always, 

Exclude After First Display, and Exclude After First Display Per Entity. You can 

access these options by right-clicking on a message as shown in the following 

screenshot: 
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Select the option you want to apply to the message. The display on the messages 

tree changes to reflect your selection. Your designations regarding message 

categories and individual messages are saved along with your session.  

 

An additional feature on the Advanced Options window is the Search for Message 

function. It allows you to search for a message using either the exact text of the 

message or its name in the list.  
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Enter the text for which you want to search in the “Message Contains:” field, and 

then click Search. The first matching item the system finds will display as 

highlighted in the tree.  

 
 

Logging 

 

The Logging tab allows you to specify how the log files are formatted and 

managed. As with the Messages tab, these settings apply to the current session 

only. 
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The Log File Format area of the tab has the following three options: Plain Text, 
Tab Delimited, and Other Delimiter.  
 
The Plain Text option writes the file without delimiters. The Tab Delimited 
option indicates that major fields are delimited by the Tab character. The Other 
Delimiter option allows you to specify a single printable character to use as a 
delimiter. 

 

The Log File Management area of the tab includes the following two settings: “Split 

log file after about **** lines”, and “Flush data to file every ****seconds”. 

 

The first setting defines the number of lines after which the system stops writing 

to one file and begin writing to a new one. 

 

The second setting defines the time interval that passes before the application 

sends its data to the log file. 

 

Rollback 
 

The Rollback tab allows you to define how large rollback files can become before 

the system splits them off into separate files, and the amount of time to delay 

between each rollback transaction.  
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In the Rollback File Management area of the tab, define the number of lines after 

which you want the system to split off the current rollback file and create a 

separate one. 

 

In the Manitou Database Configuration (for Common Import Database use) area 

of the form, enter the location of the Manitou database. The system cannot run 

the Standard Import Utility in Rollback Mode until you enter this information 

 

In the Rollback Throttling area of the tab, define the number of milliseconds you 

want to pass between ending a rollback transaction and beginning a new one. 
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Rollback Backup File 
 

Previously, when you ran a new import after a successful import, the old rollback 

file was deleted and rewritten with the new rollback information. If the data was 

not rolled back before the new import was run, the new import failed because it 

was trying to add the same data to the database that already existed from the 

previous import. Because the rollback file was deleted, however, there was no 

way to roll back that original data. 

 

To remedy the situation, the previous rollback file is now copied and named the 

same as the normal rollback file, except that it has a _BCK attached to the file 

name (for e.g., SINewSession_Rollback_BCK.sql). You can always roll back from 

one previous import using this feature.  

 

 

Common Import Database 
 

The Common Import Database allows you to import a database of tables that 

correspond to a record set. 
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Enter the location of the SQL Server, the database where the Common Import 

Database resides, and the SQL username and password, and click OK. 

 

 

Troubleshooting 
 

If the Application Server stops running, the following warning message displays:  
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If you lose your connection to the Application Server, click Refresh to reconnect . 

 

 
 

The Application Server cache may experience problems when re-running imports for 

Panel Types, Group Codes, Class Codes, and Transmitter Types. If this occurs, restart 

the Application Server. 

 

 


