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Welcome 
Bold's SnapReporter is a straight-forward, drag-and-drop tool that offers a flexibility in 
reporting processes. SnapReporter is designed to: 

 Generate Reports quickly and efficiently 

 Provide easy-to-use design elements to customize the look and feel of created Reports 

 Make creating Reports easy for those without knowledge of SQL scripting 

 

A Bold Introduction 
This manual is intended to provide instruction and reference for core features and functions 
within SnapReporter. 

 

About Bold Technologies 

Bold Technologies, an industry leader since 1981, has stood the test of time in central station 
and alarm automation software. Formerly known as Bradley On-Line Data Systems, Bold 
Technologies created the Bold Central Station Automation System and through the years, 
shaped the development of contemporary alarm monitoring by introducing faster and more 
sophisticated software innovations. We promote excellence and technological innovation 
through strategic partnerships and support of organizations dedicated to advancing industry 
standards. As a proven leader in the security industry, our strength is founded on a company-
wide commitment to helping our customer group through superb products and services. This 
commitment guides our decisions for future development. 

 

About Manitou 

Bold Technologies, recognizing that the future was about innovations within the Windows® 
world, began building the Manitou system from the ground up in 1999. The first sites went 
live on this new-age monitoring system in 2002. The Manitou system was completely 
redesigned and revolutionary, opening the alarm industry up to new concepts and ideas. 

This endeavor completely changed the industry paradigm, encouraging broad advancements 
industry-wide. 
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About SnapReporter 

SnapReporter was created in order to provide a quick and easy solution for those who may 
not be equipped with SQL experience or situations requiring reports without the need for SQL 
scripting. SnapReporter was designed to work as a supplement to the Bold Advanced Report 
Writer – providing an easy-to-use, alternate means of creating reports. While the Advanced 
Report Writer provides seamless, very fine control through SQL scripting, SnapReporter 
provides the ability to design and write reports without SQL knowledge. 

 

How to Use this Guide 
This guide has been created with the intent for one topic to flow into the next and is meant to 
be viewed as a .pdf or in electronic form. Incorporated herein are overviews, key terms, and 
definitions as well as, step-by-step instructions on how to perform different tasks within the 
SnapReporter application. 

 

System Requirements 
 Manitou CS 1.6.1 with Patch 46 or higher 

 SQL 2008r2 or greater 

 SQL provides a means for SnapReporter to store settings and logs into a database 

 

SnapReporter Overview 
Introducing SnapReporter: Our new, easy-to-use and fully-featured reporting option that 
complements the Advanced Report Writer experience, and enhances our already feature-rich 
Standard Manitou Reports. 

 

Features 
The SnapReporter is a combination of a word processor and a Report control system. It 
significantly reduces the otherwise steep learning curve associated with traditional Report 
designers and allows you to deliver highly-intuitive solutions that meet and exceed end-user 
expectations. SnapReporter elevates ease-of-use and productivity to unrivaled levels. 
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WYSIWYG Reporting 

SnapReporter is the true definition of WYSIWYG Reporting (What You See Is What You Get 
Reporting). Whether you are creating a new Report, modifying an existing Report or 
previewing it prior to printing, the document displays on screen exactly as it will look on 
paper. SnapReporter means no more dealing with the innate complexities of a traditional 
Report designer – no bands, and no more endless switching between design and preview 
modes. 

 

Extended Data Shaping 

Ease of use is not limited to the straightforward and highly productive nature of 
SnapReporter’s MSWord-inspired functionality. The rich collection of data shaping options it 
offers have been engineered to simplify the way users approach reporting going forward. 

These include: 

 Sorting Data 

 Grouping Data 

 Calculating a Summary Function 

 Applying a Calculated Field 

 Formatting Data 

 

Master-Detail 

No reporting solution is complete without an elegant way to create, maintain, and modify 
hierarchical Reports. SnapReporter removes the limits associated with traditional sub-reports 
and makes it easy to generate even the most complex master-detail layouts with ease. 

 

Integrated Report Items and Pre-Defined 
Appearances 

SnapReporter includes a powerful collection of Report elements that no professional 
reporting solution can do without. From charts to check boxes, images to barcodes... it's a 
simple “drag-and-drop” operation with SnapReporter. And of course, modifying the 
appearance of a Report is easy – a simple mouse click allows you to apply built-in appearances 
to your Report instantly. 
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Multiple Data Sources and Side-by-Side Reports 

So that users can create combined reports, SnapReporter allows you to easily bind your report 
to multiple unrelated data sources, such as Manitou and Manitou Service. And yes, side-by-
side comparison Reports are as easy to create as a standard table or multi-column layout. 

 

Compatibility, Export and Localization 

When using SnapReporter, you can open any existing RTF or DOC(X) file and quickly embed 
your business data as needed. In addition, SnapReporter provides support for all popular 
export formats, including PDF, TXT, RTF, CSV, and image formats. And just like all Bold 
Technologies’ products, SnapReporter can be fully localized to meet the language 
requirements of the user. 

 

User Interface Overview 
The SnapReporter user interface is made up of three primary elements: 

 Main toolbar, or button ribbon 

 Report editing surface 

 Docking panels 

 

 

Main Toolbar 

The main toolbar's tabs accommodate numerous actions you can perform to improve your 
SnapReporter documents. 
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Editing Surface 

The Report editing surface displays document pages as they look on paper. 
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Docking Panels 

Two docking panels are appended to the main work surface of SnapReporter: Field List and 
Report Explorer. These panels may be closed or hidden by clicking on either the X button or 
the Auto Hide button (designated by a pushpin button). When auto-hidden, you can easily 
access the panels again by navigating to the View tab, clicking the Windows option, and 
selecting the windows you want to unhide. 
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Field List 
The Field List reflects available data sources and lists their members. It can also be used to 
create custom data membersError! Reference source not found. (Applying a Calculated Field) 
hich simulate the activity of common data fields and allow you to perform various calculations 
based on your data. In the example below, a calculated field that adds one year to the 
commissioning date has been added to the Field List. 

 

 

Field List Overview 
The Field List uses the following icons to distinguish between different data objects. 
 

Icon Description 

 

 
Dataset 

 
 

 

Data table or 
view 

 

 
Parameters 
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Additionally, the Field List recognizes the following data field types. 

 

Icon Description 

 

 
Boolean 

 
 

Byte 

 

 

 

Calculated 
field 

 
 

Date-time 

 
 

Numeric 

 
 

String 

 

Report Explorer 
The Report Explorer reflects the current Report structure (for example, the fields it contains 
and any applied groupings). 

 

 

Main Toolbar Overview 
SnapReporter's main toolbar puts a wide variety of tools and actions at the user's fingertips. 

 

Standard Tools 

File 

The File tab provides options pertaining directly to the Report file. 

 Create a new Report 

 Open an existing Report 

 Save and print 



 

Bold Technologies | SnapReporter User Guide 9 

 
 

 

 

Home 

The Home tab provides all the standard formatting features typically used in manipulating a 
document. 

 Select font size, type, and special effects 

 Copy and cut 

 Format paragraphs and lists 

 Create hyperlinks 

 Search 

 

 

Data 

Use the Data tab to manage the data in a Report. 

 Set parameters (See Passing Parameters to a Report.) 

 Refresh to update any changes made 

 View source and SQL information 
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Appearance 

Quickly change a Report's appearance using a variety of available themes. 

 

 

Insert 

The Insert tab allows you to insert various objects into your Report. 

 Add tables, pictures, and charts 

 Utilize check boxes and bar codes 

 Format headers/footers and page breaks 

 Insert symbols, links, and bookmarks 

 

 

Page Layout 

The Page Layout tab provides various options for laying out the data in your Report. 

 Set margins and page size 

 Orient the page vertically or horizontally 

 Designate page breaks 

 View or hide line numbers 

 Select a page color 
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Mailings 

The Mailings tab provides you the option of viewing field codes and field results commands. It 
also allows you to locate all data fields in a Report and highlight them so you can distinguish 
them from plain text fields. Easily toggle between views by clicking the buttons. 

 Toggle between showing field codes and field result commands 

 Highlight fields 

 

 

View 

On the View tab, in addition to various viewing functions, SnapReporter adds a special section 
with the following two commands: Windows and Highlight. 

 Switch to various types of document views 

 Make a ruler visible 

 Use the zoom function 

 View different design panels and windows 

 Highlight a current element's type and boundary information 
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Review 

Easily check for spelling errors in the Review tab. 

 

 

References 

Use the tools in the References tab to update contents, as well as manage captions and 
figures. 

 

 

Optional Tools 

In addition to the standard tabs on the main toolbar, there are a few tabs that display only 
when you need them. 

Chart Tools – Design Tab 

Utilize the Design tab to apply different types of design elements to your Report. 

 Apply various chart designs - even 2D and 3D options 

 Select colors 
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 Use templates 

 Run the Chart Wizard 

 

 

Table Tools – Layout Tab 

Design the optimum look of any table in a report with the tools found in the Layout tab. 

 Determine properties 

 Manage columns and rows 

 Define cell margins and alignment 

 

 

Field Tools – Field Tab 

The Field tab provides a means of shaping the data in your Report. 

 View and manage field properties 

 Group, sort, and summarize data 
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Group Tools – Group Tab 

Once fields have been grouped, the Group tab activates. Use these tools to manage field 
groupings. 

 Apply headers and footers to groups 

 Launch the Collection Editor to manage grouped fields 

 Insert various types of separators between fields 

 

 

List 

Use tools in the List menu to manage lists in your Report. 

 Apply a header and/or footer 

 Utilize separators 

 Convert, remove, or filter a list 

 

 

Getting Started 
Getting started with SnapReporter is easy. Just identify a Report's criteria and what data you 
need. Then, drag and drop the fields you want and customize the Report to fit your needs. 
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How it Works 

By using auto-query and drag-and-drop functionality, SnapReporter makes customizing and 
generating Reports very simple. Where Advanced Report Writer requires a firm understanding 
and ability to script SQL, SnapReporter only requires an understanding of Windows-based 
functionality. Users can now easily create, customize, compare, save, print, and export 
Reports on-the-fly. 

 

Startup 

The initial implementation of the SnapReporter will be done by a Bold representative. The 
SnapReporter software may be launched from the Start menu or the Desktop. 

 Select SnapReporter from the Start Menu/Programs List (OR) 

 To launch from your Desktop, double-click the Bold SnapReporter icon 

 

 

Reporting 
SnapReporter is all about reporting - quickly, easily, and efficiently. Once SnapReporter is fully 
set up, configuring and running a custom Report is a simple process. 

 

Creating a Report 

To create Reports, you must connect SnapReporter to a data source. 

Connect to Data Source 

First, connect SnapReporter to a reliable data source. 

1. Click Data from the toolbar at the top of the screen. From the Data menu choose the 
Source button. 

Note: While multiple data sources may be available, only one database may be used at 
a time. 
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2. The SQL Server Parameters window displays. 

 

3. Enter the appropriate database details for each Manitou system from which you want 
to report. 

IMPORTANT: 

 There is no automated rollover for Snap Reports if you perform a failover and 
your SQL Server is on a different system than your Manitou services and 
SnapReporter. In such an instance, you will need to change the data source 
each time you perform a failover. 

 If your SQL Server is on the same system as your Manitou services and 
SnapReporter, you can set the data source to localhost and the rollover should 
occur without issue. Please note, localhost is the correct selection on the 
server. However, on a workstation the named server should be, for example, 
“manitou1” or “manitou2”. 

 Please note that SnapReporter must be installed on the Manitou Server in 
order to render reports from the Manitou Database. 

4. Enter the host address of the Manitou Broker in the Manitou box. 

Important: The Manitou box must be populated to correctly add the connection. 

5. Click Test to check the connection. 
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6. When the connection is acknowledged, click OK on the Info window, then click OK on 
the SQL Server Parameters window. 

7. Add a connection for each machine where the Broker could run. 

Note: When you click the Source button again, the original connection information 
displays in the SQL Server Parameters window. To create a new server connection, 
simply type over the existing text with the new connection information. 

8. The Data Source link displays on the left side of the Bold SnapReporter main screen. 

 

9. Click the Data Source link to populate the Field List on the right side of the screen. 
  



 

Bold Technologies | SnapReporter User Guide 18 

 
 

Note: If the Data Source link does not display as described, click View and then click 
Windows. Confirm that Data Source is selected as shown in the following screenshot: 

 

 

Create a New Report 

Once SnapReporter has been connected to a data source, you can create a new Report. The 
Report creation process in SnapReporter is as simple as selecting the required items in the 
Field List and dropping them onto the surface of the Report. 

On the File menu, click New. 

 

Create a Standard Report 

A standard Report consists of primary field types. These are the fields listed in the Field list 
that do not include additional sub-types. 

1. Begin by identifying the criteria you want to include in your Report. 

2. Next, select the field types from the Field List on the right side of your screen. 

Note: We recommend that you add fields by pressing and holding down the Ctrl key 
while clicking on individual fields instead of individually dragging each field onto the 
Report surface. 

3. While still holding down the Ctrl and mouse button, drag the field types onto the 
Report editing surface. 

The Report now auto-generates by placing the data into adjustable columns. 
Additionally, all fields you include in the Report will now also display in the Report 
Explorer list located just below the Field List. 
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Create a Master Detail Report 

A Master Detail Report consists of detailed information, including sub-types, within a 
particular field group. Field groups are those field types with drill-down selections of sub-
types that are designated by arrows in the Field List. 

1. Begin by identifying the criteria you want to include in your Report. 

2. Select the field types from the Field List on the right side of your screen. 

Note: We recommend that you add fields by pressing and holding down the Ctrl key 
while clicking on specific fields instead of individually dragging each field onto the 
Report surface. 

3. Once you have selected the heading field types, expand any additional field groups 
and select the field sub-types you want to include. 

4. While still holding down the Ctrl and mouse button, drag the selected field types and 
sub-types onto the Report editing surface. 

5. The Report now auto-generates by placing the requested data into easily adjustable 
tables of data. Additionally, all fields included in the Report now also display in the 
Report Explorer list located just below the Field List. 
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For additional information on how to customize and edit your Reports, please refer to 
one of the following sections: 

 Editing a Report 

 Managing Data 

 Saving and Distributing a Report 

 

Open an Existing Report 

Opening an existing SnapReporter Report only requires browsing to the appropriate folder. 

1. Navigate to the File tab on the main toolbar, and then click Open. 

Note: If the buttons on the File tab are not activated, click the Data Source to enable it. 

2. Browse to the SnapReporter folder that contains existing .bsr Report files, or select 
another file location. 
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3. Select the appropriate Report by clicking to highlight the Report name, and then click 
Open. 

The Report opens onto the Report editing surface with SnapReporter. 

 

Editing a Report 
Just like with word processing tools, SnapReporter provides quick and easy ways to adjust 
layout and design. 

 

Moving from Field to Field 

Jump from section to section within a multiple-field Report by clicking on the list titles within 
the Report Explorer panel on the right side of your screen. Once clicked, the Report will jump 
to that specific section and highlight the list header. 
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Adding and Removing Fields and Columns in a 
Standard Report 

Fields may be added or removed easily from a generated Report. Adding a field may be done 
by either first adding a column or by dragging and dropping the field type directly into place 
on the Report. 

Add a Column 

1. Click in an existing column where you want to add a new column. 

2. Right-click and select Split Cells. 

3. Right-click again and select either Insert Columns to the Left or Insert Columns to the 
Right of the current cursor position. 

4. Once added, select the field you want to add and drag it into the blank column. 

Drag and Drop a Field Type 

Additionally, you can drag and drop fields onto your Report. 

1. Locate the field you want from the Field List. 

2. Click and drag the field to the Report, positioning the cursor where you want the field 
to display. 

3. When the blue line displays, release the mouse button to drop the data into place. 

Remove a Column 

1. Click within the column of data you want to remove. 

2. Right-click and select Delete Cells, and then select Delete entire column. 
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3. Click OK at the confirmation prompt. 

4. Additionally, if you place a field in error, use the Undo button from the File menu to 
reverse the action. 

 

Adding and Removing Fields and Columns in a 
Master Detail Report 

As above, you can add and remove columns by right-clicking and then selecting the 
appropriate action. With column-rich Master Detail Reports, it may be easier to remove 
particular cells. 

1. To remove a cell, position the cursor on the field cell you want to delete and right-
click. 

2. Select Delete Cells, and then choose a delete option (Shift cells left, Shift cells up, 
Delete entire row, or Delete entire column). 

3. Click OK. 

Additionally, you can drag and drop field types into place, ensuring that the blue line displays 
where you want to position the information. 

Pay close attention to the top of the column when dealing with Master Detail Reports. 
Columns begin and end at various locations within a Master Detail Report. In the example 
below, each highlighted box denotes a different column. With so many columns available, you 
can see why it is important to determine exactly where you want each column to display 
when you are adding or removing fields. 
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Adjusting the Number of Data Rows 

You can limit the number of rows that display in your SnapReporter Report. To increase 
performance, SnapReporter limits incoming data to only 20 records by default. Therefore, all 
the Report data only displays to the user when in Print Preview. However, you can define the 
number of records that display, as well as eliminate the limit entirely. See Print or Export Your 
Snap Report. 

To specify a row limit for your Report, click a field from the Field List to select it. Then on the 
Data tab of the main toolbar, select the number of data rows on the Row Limit drop-down list 
menu. 

 

Note: The Row Limit setting does not affect the number of records that display in Print 
Preview (which always displays all available records). See Print or Export Your Snap Report. 
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Applying a Date Format 

1. To provide a date format to a date-related column (such as Commission Date), select 
any field in this column to activate the Field menu in the main toolbar. 

2. In the Field menu, click Properties and select FormatString from the drop-down list by 
clicking the Ellipsis button. 

3. In the FormatString Editor window, select the format you want and then click OK. An 
example of the selected date format shows in the Sample box above the formatting 
options. 

 

4. To apply this change to all fields in the column, click within another row. 

 

Adjusting Tables, Columns, and Rows 

You can easily resize column width by placing the cursor on the line in between two columns, 
and using click-and-drag to adjust the width. Do the same to adjust row height. 

Many actions are available to edit rows and columns – such as add a column/row, borders 
and shading, etc. – within the Table Tools Design and Layout menus. See Chart Tools – Design 
Tab and Table Tools – Layout Tab. 

Apply changes and edits to an entire Report by editing the top cell of a column or table, and 
then clicking elsewhere in the Report. 
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Example: Let's say you create a Master Detail Report with numerous tables separating 
Customers and their related contact information. You need to add a space to adjust the 
contact name. Click in the first contact name cell in the top table. Press Enter to create a one 
line space above the contact name. To apply the change to all contact name cells in all tables 
of the document, click any other cell in the Report and it will automatically update. 

 

Arranging Content 

Moving Data 

1. If you need to adjust existing data, make adjustments to the top-most field. If a field is 
not in the position you want, move the data from one column to another rather than 
trying to move the headers. 

2. Click and drag the field to where you want it. All related fields will self-adjust to the 
same location. 

3. Retype the headers. 

 

Swapping Data 

1. To swap data in two different fields, cut the data in the first field using the Cut 
command. 

2. Drag the data in the second field to the location of the first field. 

3. Paste the information copied to the clipboard into the now empty second field 
location. 

 

Managing Data 
There are several ways to manipulate the data you want to include and display in your Report. 
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Sorting Data 

You can sort data using either the ribbon panel or context menu. 

To sort using the context menu: right-click the field you need to sort, and click Sort Ascending 
or Sort Descending. 

 

To sort from the Field menu: select the Field tab from the main menu, and select Sort 
Ascending or Sort Descending. 
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Grouping Data 

To group using the context menu: right-click the field you need to group, and click Sort 
Ascending or Sort Descending. 

 

To group from the Field ribbon menu: select the Field tab from the main menu, and choose 
Group By Field. 

 

Note: Grouping fields activates the Group menu on the main toolbar. For more information 
about tools available in the Group menu. See   
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Group Tools – Group Tab. 

 

Managing Grouped Headers and Footers 

SnapReporter allows you to use headers and footers for groups. For a newly created group, 
only the group header is added by default. 

To manage the availability of group headers and footers (for example, to include a group 
footer in your Report, or to remove the header and footer completely) click a field to select it, 
and then click the List tab in the main toolbar. 

Select Header or Footer. Then, select the Add or Remove command. 

 

 

Formatting Data 

You can format cells in data columns by date/time, number, percent, currency, and special 
categories. 

1. Open your SnapReporter Report. 

2. Select the field you want to format. 

3. In the activated Field tab, click the Properties button. 

4. From the list of options, click the Ellipsis button at the right edge of the FormatString 
field. 

5. In the FormatString Editor box, specify Category and Standard Types. 

6. Click OK. To apply the changes to all fields in the column, click any other field cell in 
your Report. 
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Customizing a Report 
Adding Graphics 

Adding graphics to a SnapReporter Report is easy, but it increases the file size so that the 
system might limit your ability to distribute your Report electronically. For this reason, we 
recommend limiting your use of added graphics. 

1. With your Report open, position the cursor at the location you want to insert the 
graphic. 

2. Click Insert, and then click Picture. 

3. Browse to and select the graphic you want to add. 

4. Click OK. 
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Calculating a Summary Function 

If you want to view totals for specific numerical data, you can apply a summary function to 
your Report. Summary functions can be used to determine the count, sum, average, 
minimum, or maximum of numerical-based fields. 

1. Open your SnapReporter Report. 

2. Select the field where you want to apply the summary function. 

3. In the activated Field tab, click the Summary button, then select the summary function 
you want to add. 

 

 

Summary Function Customization 

In addition to the standard summary functions available, you can customize summary 
functions by using the Summary Editor window. 

1. Click the field to which you want to add the summary function. 

2. Click the Field tab, and then click Properties. 

3. Click the Summary field Ellipsis to display the Summary Editor window. 
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4. Create the summary function you want, and then click OK. 

Note: To learn how you can apply currency and date time formatting to fields in your 
SnapReporter Reports, see Applying a Date Format. 

 

Applying a Calculated Field 

To calculate the product of two fields in a Report, you must create and add a calculated field. 

Create a Calculated Field 

1. Open an existing SnapReporter Report, or create a new one. 

2. Right-click on any field type in the Field List window to create a calculated field, then 
choose Add Calculated Field. 
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The calculated field you created now displays in the Field List. 

 

Note: Please note that the Field List displays fields in alphabetical order. 
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3. Then, right-click the calculated field you created, and select Edit Calculated Fields 

 

4. In the Collection Editor window, click the Ellipsis button on the right edge of the 
Expression field. 
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5. Create your expression on the Expression Editor window, and click OK. 

 

 

6. Click the Ellipsis button on the right edge of the Field Type field, and select the type of 
field you want to add. 

7. Enter a name for your new calculated field in the Name field, and click OK. 
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Add a Calculated Field 

Now, you can add the calculated field to your Report as you would a simple data field. Drag 
and drop the field where you want it in your Report. 
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Passing Parameters to a Report 

SnapReporter makes it easy to create a parameter (we are using a string parameter in this 
section's example) and apply it to your Report. 

1. To create a parameter, switch to the Field List window, right-click the Parameters 
option (at the bottom of the list), and choose Add Parameter. 

 

2. Right-click the parameter you just added, and select Edit Parameters. 
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3. In the Collection Editor window, enter a parameter Name, and a default static Value 
for the parameter. 

4. Click the Ellipsis button at the right edge of the Type field, and select the parameter 
type you want. 

Note: This type corresponds to the value that a parameter can receive (for example, 
you cannot assign a string value to a numeric parameter). 
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5. Click OK. 

6. Click the Data tab in the main toolbar, and then click Filter. 

7. In the Filter Expression window, click the + to display the filtering expression options. 
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8. Once the default filtering expression displays, click the links to display drop-down 
menus for each part of the filtering expression you want to create. (For the visual 
examples in this section, we are using the CUSTOMER_ID data field Begins with the 
?ContractID parameter). 

 

 

9. Click OK, and then click Save. 

You can now use the parameter when creating a Report just by dropping the related 
fields onto the Report editing surface. SnapReporter now filters the associated data 
based on the parameter values you specified. 
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Adding a Date Range Parameter 

1. To add a date range parameter, open the Data menu and click Filter. 

 

2. Click the + icon. 
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3. Click the link for the first field. 

 

4. Select a date-specific field option from the dropdown list (for example, “Commission 
Date”). 
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5. Click the Equals link. 

 

6. Select the Is between option from the dropdown menu. 

 

7. Enter a starting date in the first <enter a value> field and an ending date in the second 
<enter a value field>, and click OK. 

8. Click Save. 

Now the Report you generate will only include dates in the range you set. 
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Note: All dates in Manitou are stored in a format that includes the date and time. 
Using the Equals date filtering option to set a date parameter is not generally effective 
because SnapReporter only shows results where the date in Manitou equals the 
specified date at 12:00am. Using the Is between date filter, you can select data for 
events that occurred between 12:00am on the first specified date and 12:00am on the 
second specified date. 

However, selecting a date parameter of Is Tomorrow, Is Today, or Is Yesterday will 
work effectively and include all times during the specified day. 

 

Previewing the Parameterized Report 

To view how your Report will look on paper, click the File menu in the main toolbar, and then 
click the Print Preview. 
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Importing Parameters into Manitou 

SnapReporter has a number of quick ways to create parameters for Reports you want to 
import into Manitou. 

1. Navigate to the Data menu, and then select Parameters. 

 

2. In the Parameter Wizard, select the parameters you want to apply to your imported 
Report, and click OK. 

3. Save the Report, and import it into Manitou. 

Note: To learn about importing a Report into Manitou, refer to Saving and Distributing 
a Report. 
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Creating a Multi-Column Report 

1. Open an existing Report or create a new one. 

2. In the main toolbar, click the Page Layout tab. 

3. Click Columns, and select the number of columns you want for your Report. 

 

4. To define more than three columns, click More Columns. In the resulting Columns 
dialog, customize the Report layout you want. Click OK to apply. 
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The following image illustrates the result: 

 

 

Creating a Side-by-Side Report 

Side-by-side Reports can be helpful when you want to compare different types of data. 

1. Open an existing Report, or create a new one. 

2. To add a table to your Report, click the Insert tab on the main toolbar, and then click 
Table. 

3. Move the cursor over the resulting grid to select the number of columns and rows you 
want. The table layout you selected displays at the bottom of the grid. 

Note: In the example below, one row and two columns have been selected. This 
displays on the bottom of the grid as 1x2. 
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Additionally, you can set table borders by clicking Borders on the Design tab under 
Table Tools. 

 

4. Once you have created the table, drop the appropriate fields from the Field List into the 
table's columns. 
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In the example below, we used the CUSTOMER_PLANS.PLANS_PICTURE and 
CUSTOMER_PLANS.PLANS_LAYER_DESCRIPTION fields to populate the table. 

 

 

Adding a Chart to your Report 

SnapReporter provides an easy way to create and customize your charts. If you need more 
complex chart options, SnapReporter also provides a Chart Wizard. 

1. To add a chart to a Report, select Chart on the Insert tab of the main toolbar. 

 

2. On the default chart that displays, the blue circles correspond to regions for values and 
arguments. From the Field List window, select and drop the correlating fields onto the 
chart values and arguments locations. 

Note: In the example below, we are using the EVENT_CODE field for the values region 
and the DATE_VALUE field for the arguments region of the chart. 
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Changing Chart Type 

You can change the chart type by clicking on the chart and then selecting another chart type 
from the Design tab on the main toolbar. You can adjust the chart's palette and appearance 
on the Design tab, as well. 
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Your chart is now ready. 

 

To view how your chart will look on paper, click Print Preview on the File menu. 
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Saving and Distributing a Report 
Saving and distributing reports from SnapReporter works like any other Windows-based 
software. 
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Save Your Snap Report 

To save your Report, click Save As on the File menu. 

 

1. Enter a name for your Report in the File name box. 

2. If you want to save your Report as a file type other than .bsr (.bsr is the default file type), 
select another option from the Save as type box. 

Note: Selecting another file type option will prevent you from further editing your Report in 
SnapReporter. 

 

 

3. Click Save. 
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4. If you want to remove the data from your Report so you can share the format (but not the 
data) with other SnapReporter users, select the Remove report data check box. 

5. Click OK. 

 

Print or Export Your Snap Report 

To print a Report, select a print option from the File menu. 

To export to .csv, ensure your Report is in column format and all headers have been removed. 
Then, select Save As and choose Comma Separated Values (*.csv) from the Save as type box. 

To export your Report to a .pdf or image file, click Print Preview from the File menu. From the 
Preview screen, click the down arrow next to the Envelope icon, and select a file format. 
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Importing a Report into Manitou 
You can import Reports from SnapReporter into Manitou using Manitou's Supervisor 
Workstation. 

1. From the Supervisor Workstation, navigate to the Reports menu and select Report 
Templates. 

 

2. Click Edit. 

3. Find the External section on the Navigation Tree, and select the External child node 
you want to designate as the destination for your Report. 

 

4. Click Add. 
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5. In the Add Report Definition dialog, enter a name for your Report, and click the 
Ellipsis button next to the Template File box. 

 

6. Browse to the location of the file you want to import, and click Open. 
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7. At the Add Report Definition dialog, click OK to import the Report into Manitou. 

 

8. To confirm the import was successful, click System Reports from the Reports menu 
and view the newly imported Report in the available Reports list. 

 

All your parameters are available to run the Report like any other Manitou Report. 

Note: Please note that images, charts, and graphics imported into Manitou do not 
display as they would from SnapReporter. We hope to address this issue in a future 
release of Manitou. 

 


